PAT树的深度优先搜索(dfs)和广度优先搜索(bfs)

dfs和bfs都是常用的搜索算法,结合PAT1094,简单动手分别以dfs和bfs实现树的遍历吧。

1094 The Largest Generation (25 分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

 

Sample Output:

9 4

题目大意:给你一棵树,让你找出哪一层的节点个数最多,输出节点个数和对应的层数。

dfs:

 

#include<cstdio>
#include<iostream>
#include<vector>
const int maxn=105;
vector<int> tree[maxn];
int sum[maxn];//记录每一层的节点个数
int n,m;
void dfs(int level,int node){
	sum[level]++;
	for(int i=0;i<tree[node].size();i++){
		dfs(level+1,tree[node][i]);
	}
}

int main()
{
	cin>>n>>m;
	for(int i=0;i<m;i++){
		int id,num;
		cin>>id>>num;
		for(int j=0;j<num;j++){
			int child;
			cin>>child;
			tree[id].push_back(child);
		}
	}
	dfs(1,1);
	int maxnum=-1,maxlevel=-1;
	for(int i=0;i<maxn;i++){
		if(sum[i]>maxnum){
			maxnum=sum[i];
			maxlevel=i;
		}
	}
	cout<<maxnum<<" "<<maxlevel<<endl;
	return 0;
}

bfs

#include<cstdio>
#include<iostream>
#include<vector>
#include<queue>
using namespace std;
const int maxn=105;
vector<int> tree[maxn];
int sum[maxn];
int level[maxn]; //记录节点对应的层数
int n,m;
void bfs(){
	queue<int> q;
	q.push(1);
	level[1]=1;
	while(!q.empty()){
		int node=q.front(); q.pop();
		sum[level[node]]++;
		for(int i=0;i<tree[node].size();i++){
			level[tree[node][i]]=level[node]+1;
			q.push(tree[node][i]);
		}
	}
}
int main()
{
	cin>>n>>m;
	for(int i=0;i<m;i++){
		int id,num;
		cin>>id>>num;
		for(int j=0;j<num;j++){
			int child;
			cin>>child;
			tree[id].push_back(child);
		}
	}
	bfs();
	int maxnum=-1,maxlevel=-1;
	for(int i=0;i<maxn;i++){
		if(sum[i]>maxnum){
			maxnum=sum[i];
			maxlevel=i;
		}
	}
	cout<<maxnum<<" "<<maxlevel<<endl;
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值