POJ3666 离散化的dp

Description

A straight dirt road connects two fields on FJ’s farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, … , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . … , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

| A 1 - B 1| + | A 2 - B 2| + … + | AN - BN |

Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

  • Line 1: A single integer: N
  • Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

  • Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3

这题我是想的要考虑两种情况一种是降序一种是升序写完以后两个比较
但是太蠢了
然后发现这两种其实是可以合并的
那就是两个循环都从头开始
如果后的b比前面的差要小那么就取后面的就是降序
反之则是升序
因为一开始使用sort拍好的数组所以他一定是有一个顺序
mi一直都是从小到大,从小到大的遍历,不会直接弄到他自己产生0的这种尴尬情况…
也基本上相当于另开了一个循环..
从1一直循环到b的那种…
相比而言真的是很蠢..
这种思想值得牢记

另外poj好像对abs这个函数里面传的值得类型要求很毛病
不int就编译错误妈的智障

#include<iostream>
#include<string>
#include<memory.h>
#include<cstdio>
#include<cmath>
#include<stack>
#include<algorithm>
using namespace std;
long long zhi[2001];
long long zhi1[2001];
long long dp[4000][4000];
int main()
{
    int n;
    cin >> n;
    for (int a = 1;a <= n;a++)
    {
        cin >> zhi[a];
        zhi1[a] = zhi[a];
    }
    sort(zhi1 + 1, zhi1 + n + 1);
    for (int a = 1;a <= n;a++)
    {
        long long mi = dp[a - 1][1];
        for (int b = 1;b <= n;b++)
        {
            mi = min(dp[a - 1][b], mi);
            dp[a][b] = abs(int(zhi[a] - zhi1[b])) + mi;
        }
    }
    long long sum = 0x7fffffff;
    for (int a = 1;a <= n;a++)sum = min(sum, dp[n][a]);
    cout << sum << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值