poj2449 第k短路....A*+最短路

Description

“Good man never makes girls wait or breaks an appointment!” said the mandarin duck father. Softly touching his little ducks’ head, he told them a story.

“Prince Remmarguts lives in his kingdom UDF – United Delta of Freedom. One day their neighboring country sent them Princess Uyuw on a diplomatic mission.”

“Erenow, the princess sent Remmarguts a letter, informing him that she would come to the hall and hold commercial talks with UDF if and only if the prince go and meet her via the K-th shortest path. (in fact, Uyuw does not want to come at all)”

Being interested in the trade development and such a lovely girl, Prince Remmarguts really became enamored. He needs you - the prime minister’s help!

DETAILS: UDF’s capital consists of N stations. The hall is numbered S, while the station numbered T denotes prince’ current place. M muddy directed sideways connect some of the stations. Remmarguts’ path to welcome the princess might include the same station twice or more than twice, even it is the station with number S or T. Different paths with same length will be considered disparate.
Input

The first line contains two integer numbers N and M (1 <= N <= 1000, 0 <= M <= 100000). Stations are numbered from 1 to N. Each of the following M lines contains three integer numbers A, B and T (1 <= A, B <= N, 1 <= T <= 100). It shows that there is a directed sideway from A-th station to B-th station with time T.

The last line consists of three integer numbers S, T and K (1 <= S, T <= N, 1 <= K <= 1000).
Output

A single line consisting of a single integer number: the length (time required) to welcome Princess Uyuw using the K-th shortest path. If K-th shortest path does not exist, you should output “-1” (without quotes) instead.
Sample Input

2 2
1 2 5
2 1 4
1 2 2
Sample Output

14

先跑一遍最短路
然后就开始A*搜索
叫的这么好听其实就是个bfs
用优先队列可以贪心
第几次碰到终点就是第几k
然后他的启发式是说的
当前走的和当前点到目的点的最小值

#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <algorithm>
#include<iostream>
using namespace std;
vector<int>tu[1001],ftu[1001],juli[1001],fjuli[1001];
int s,e,k;
long long yijing[1001],daon[1001];
struct p
{
    long long dian,chang;
    p (int diann=0,int changg=0):dian(diann),chang(changg){}
    bool operator < (const p&a)const{
        return chang+daon[dian]>a.chang+daon[a.dian];
    }
};
int inf=0x3f3f3f3f;
int main()
{
    #define int long long
    int n,m;
    cin>>n>>m;
    int q,w,e;
    for(int a=1;a<=m;a++)
    {
        scanf("%d%d%d",&q,&w,&e);
        ftu[q].push_back(w);
        tu[w].push_back(q);
        fjuli[q].push_back(e);
        juli[w].push_back(e);
    }
    cin>>s>>e>>k;
    priority_queue<p>qq;
    memset(daon,0x3f,sizeof(daon));
    daon[e]=0;
    qq.push(p(e,0));
    if(s==e)k++;
    while(!qq.empty())
    {
        p zas=qq.top();
        qq.pop();
        if(yijing[zas.dian])continue;
        yijing[zas.dian]=1;
        for(int a=0;a<tu[zas.dian].size();a++)
        {
            if(yijing[tu[zas.dian][a]])continue;
            if(daon[tu[zas.dian][a]]>daon[zas.dian]+juli[zas.dian][a])
            {
                daon[tu[zas.dian][a]]=daon[zas.dian]+juli[zas.dian][a];
                qq.push(p(tu[zas.dian][a],daon[tu[zas.dian][a]]));
            }
        }
    }
    qq.push(p(s,0)),k--;
    int jieguo=-1;
    if(daon[s]==inf)
    {
        cout<<-1<<endl;
        return 0;
    }
    while(!qq.empty())
    {
        p zas=qq.top();
        qq.pop();
        if(zas.dian==e)
        {
            if(k)k--;
            else
            {
                jieguo=zas.chang;
                break;
            }
        }
        for(int a=0;a<ftu[zas.dian].size();a++)
        {
            qq.push(p(ftu[zas.dian][a],zas.chang+fjuli[zas.dian][a]));
        }
    }
    cout<<jieguo<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值