HDU1045 (3/600)

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input file.
Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
Sample Input
4
.X..
….
XX..
….
2
XX
.X
3
.X.
X.X
.X.
3

.XX
.XX
4
….
….
….
….
0
Sample Output
5
1
5
2
4

和那个棋盘的题非常类似
不一样的是建图的部分
用墙可以让一行变两行
这种操作闻所未闻。。。
学会了…..

#include <iostream>
#include <cstring>
#include<algorithm>
#include <cstdio>
#include<string>
using namespace std;
int n;
string tu[4];
int ml[4][4], mh[4][4];
int mp[18][18],use[13],vis[13];
int zhao(int gen)
{
    for (int a = 1; a < 17; a++)
    {
        if (mp[gen][a] == -1)continue;
        if (vis[a])continue;
        vis[a] = 1;
        if (use[a] == 0 || zhao(use[a]) == 1)
        {
            use[a] = gen;
            return 1;
        }
    }
    return 0;
}
int xiongyali()
{
    int fs = 0;
    memset(use, 0, sizeof(use));
    for (int a = 1; a < 17; a++)
    {
        memset(vis, 0, sizeof(vis));
        if (zhao(a))fs++;
    }
    return fs;
}
int main()
{
    while (cin >> n)
    {
        if (!n)return 0;
        memset(ml, 0, sizeof(ml));
        memset(mh, 0, sizeof(mh));

        for (int a = 0; a < n; a++)cin >> tu[a];
        int hh = 0;
        for (int a = 0; a < n; a++)
        {
            for (int b = 0; b < n; b++)
            {
                while (b<n&&tu[a][b] == 'X'&&b<n)b++;
                hh++;
                while (b < n&&tu[a][b] != 'X')mh[a][b] = hh,b++;
            }
        }
        int ll = 0;
        for (int b = 0; b < n; b++)
        {
            for (int a = 0; a < n; a++)
            {
                while (a < n&&tu[a][b] == 'X')a++;
                ll++;
                while (a < n&&tu[a][b] != 'X')ml[a][b] = ll,a++;
            }
        }
        memset(mp, -1, sizeof(mp));
        for (int a = 0; a < n; a++)
        {
            for (int b = 0; b < n; b++)
            {
                if (tu[a][b] == 'X')continue;
                mp[mh[a][b]][ml[a][b]] = 1;
            }
        }
        printf("%d\n", xiongyali());
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
蛋白质是生物体中普遍存在的一类重要生物大分子,由天然氨基酸通过肽键连接而成。它具有复杂的分子结构和特定的生物功能,是表达生物遗传性状的一类主要物质。 蛋白质的结构可分为四级:一级结构是组成蛋白质多肽链的线性氨基酸序列;二级结构是依靠不同氨基酸之间的C=O和N-H基团间的氢键形成的稳定结构,主要为α螺旋和β折叠;三级结构是通过多个二级结构元素在三维空间的排列所形成的一个蛋白质分子的三维结构;四级结构用于描述由不同多肽链(亚基)间相互作用形成具有功能的蛋白质复合物分子。 蛋白质在生物体内具有多种功能,包括提供能量、维持电解质平衡、信息交流、构成人的身体以及免疫等。例如,蛋白质分解可以为人体提供能量,每克蛋白质能产生4千卡的热能;血液里的蛋白质能帮助维持体内的酸碱平衡和血液的渗透压;蛋白质是组成人体器官组织的重要物质,可以修复受损的器官功能,以及维持细胞的生长和更新;蛋白质也是构成多种生理活性的物质,如免疫球蛋白,具有维持机体正常免疫功能的作用。 蛋白质的合成是指生物按照从脱氧核糖核酸(DNA)转录得到的信使核糖核酸(mRNA)上的遗传信息合成蛋白质的过程。这个过程包括氨基酸的活化、多肽链合成的起始、肽链的延长、肽链的终止和释放以及蛋白质合成后的加工修饰等步骤。 蛋白质降解是指食物中的蛋白质经过蛋白质降解酶的作用降解为多肽和氨基酸然后被人体吸收的过程。这个过程在细胞的生理活动中发挥着极其重要的作用,例如将蛋白质降解后成为小分子的氨基酸,并被循环利用;处理错误折叠的蛋白质以及多余组分,使之降解,以防机体产生错误应答。 总的来说,蛋白质是生物体内不可或缺的一类重要物质,对于维持生物体的正常生理功能具有至关重要的作用。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值