HDU3829 (9/600)

The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child’s like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child’s like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.
Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child’s like-animal and dislike-animal, C for cat and D for dog. (See sample for details)
Output
For each case, output a single integer: the maximum number of happy children.
Sample Input
1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1
Sample Output
1
3

Hint
Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.

这个题是在偶二分图专题里做的
但是我怎么都只能想到猫和狗匹配
然后匹配好多次就是带权
然后最后求最大权…
甚至想网最大流?

这思路其实是非常非常傻逼的
因为最大流标一个负流量他肯定不往这边跑….
都最大流了傻逼才在一坨正流量里往负的这里走….

费用流?
这个….可能不行兄弟(其实是我没想好要怎么建图….总感觉应该可以的吧…过会再看看?

所以发现居然是人和人建边….
通过猫狗来匹配…
匹配的都是矛盾的……
其实相当于把点拆成了两个….
减掉的其实是匹配的矛盾边中的一边….

剩下的最大独立集即为所求…

还是不够熟练….这个最大独立集的意思就是互相无关的最多的点的集合

(不不不我还是觉得可以费用流….

#include <iostream>
#include <cstring>
#include<algorithm>
#include <cstdio>
#include<vector>
#include<queue>
#include<string>
#include<map>
#include<stack>
using namespace std;
string xh[601], bxh[601];
int tu[601][601],use[601],vis[601];
int n, m,p;
int zhao(int gen)
{
    for (int a = 1; a <= p; a++)
    {
        if (vis[a])continue;
        if (tu[gen][a]==-1)continue;
        vis[a] = 1;
        if (use[a] == 0 || zhao(use[a]) == 1)
        {
            use[a] = gen;
            return 1;
        }
    }
    return 0;
}
int xiongyali()
{
    int fs = 0;
    memset(use, 0, sizeof(use));
    for (int a = 1; a <= p; a++)
    {
        memset(vis, 0, sizeof(vis));
        if (zhao(a))fs++;
    }
    return fs;
}
int main()
{

    while (cin >> n >> m>>p)
    {
        for (int a = 1; a <= p; a++)cin >> xh[a] >> bxh[a];
        memset(tu, -1, sizeof(tu));
        for (int a = 1; a <= p; a++)
        {
            for (int b = 1; b<=p; b++)
            {
                if (xh[a] == bxh[b]||xh[b]==bxh[a])
                {
                    tu[a][b] =tu[b][a] =1;
                }
            }
        }
        int tt= xiongyali();
        printf("%d\n", p - tt/2);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值