HDU - 3032(39/600)

Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s00, s11, …., sN−1N−1, representing heaps with s00, s11, …, sN−1N−1 objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ Sii ≤ 2^31 - 1)
Output
For each test case, output a line which contains either “Alice” or “Bob”, which is the winner of this game. Alice will play first. You may asume they never make mistakes.
Sample Input
2
3
2 2 3
2
3 3
Sample Output
Alice
Bob

这个题是我第一次接触SG函数
sg函数的意思大概就是一个dfs树
当前节点的值就是所有后继里面不存在的最小的一个非负整数
nim比较特殊
他是所有节点分开求的
那么只要分开数自己求sg值
最后亦或了就可以

#include<bits/stdc++.h>
using namespace std;
#define int long long 
main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        cin>>n;
        int zz=0,ww;
        for(int a=1;a<=n;a++)
        {
            scanf("%lld",&ww);
            if(ww%4==2||ww%4==1)
            {
                int rr=ww%4;
                int ee=ww/4;
                zz^=(ee*4+rr);
            }
            if(ww%4==3)
            {
                int rr=ww%4;
                int ee=ww/4;
                zz^=(ee*4+4);
            }
            if(ww%4==0)
            {
                int rr=ww%4;
                int ee=ww/4;
                ee--;
                zz^=(ee*4+3);
            }
        }
        if(zz)printf("Alice\n");
        else printf("Bob\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值