数据结构实验之栈二:一般算术表达式转换成后缀式

                                                            数据结构实验之栈二:一般算术表达式转换成后缀式

Description

对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。

Input

输入一个算术表达式,以‘#’字符作为结束标志。

Output

输出该表达式转换所得到的后缀式。

Sample Input

a*b+(c-d/e)*f#

Sample Output

ab*cde/-f*+

Hint

 
#include<stdio.h>
#include<ctype.h>
int cpa(char ch){
    switch(ch){
        case '(': return 0;
        case '+':
        case '-':
            return 1;
        case '*':
        case '/':
            return 2;
        case ')':
            return 3;
    }
}
int main(){
    char shi[1000], str;
    int front=0;
    while(scanf("%c", &str), str != '#') {
        if(isalpha(str))
            printf("%c", str);
        else {
            if(front==0) shi[++front] = str;
            else{
                if(cpa(str)==0)
                    shi[++front] = str;
                else if(cpa(str)==3) {
                    while(shi[front]!='(')
                        { printf("%c", shi[front]); front--; }
                    front--;
                }
                else if(cpa(str) <= cpa(shi[front]) )  {
                    printf("%c", shi[front]);
                    front--;
                    shi[++front]  = str;
                }
                else    //其余情况为<span style="font-family: 'times new roman';">cpa(str)  >  cpa(shi[front])</span>
                    shi[++front] = str;
            }
        }
    }
    while(front!=0) {
        printf("%c", shi[front]);
        front--;
    }
    printf("\n");
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Uri · Boyka

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值