POJ 1068 Parencodings(暴力枚举)

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22856 Accepted: 13399

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


题目大意:对于一个由左括号'('和右括号')'组成的字符串S,给出其P序列,输出对应的W序列(P序列中P[i]表示在第i个右括号有P[i]个左括号,W序列中W[i]表示由第i个右括号组成的括号对内有W[i]-1对括号,详见样例)。
基本思路是先由P序列还原出每个右括号在S串中的位置。最后循环每次从后往前扫描到与第i个右括号对应的左括号,输出区间内的左括号数。因为n最大为20,所以暴力也不会超时。



#include<stack>
#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;

const int MAXN=1e5+20;
int n,r[MAXN],num[MAXN],is[MAXN],vis[MAXN];

int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    int tcase;
    scanf("%d",&tcase);
    while(tcase--)
    {
        memset(r,0,sizeof(r));
        memset(num,0,sizeof(num));
        memset(is,0,sizeof(is));
        memset(vis,0,sizeof(vis));
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&num[i]);
            if(i==0)
                r[i]=num[i]+1;
            else
                r[i]=r[i-1]+num[i]-num[i-1]+1;
            is[r[i]]=1;
        }
        //for(int i=0;i<n;i++)
        //    printf("%d ",r[i]);
        //puts("");
        //for(int i=1;i<=2*n;i++)
        //    printf("%s",is[i]?" )":"(");
        //puts("");
        for(int i=0;i<n;i++)
        {
            int cnt=0;
            for(int j=r[i]-1;j>=1;j--)
            {
                if(!is[j])
                    cnt++;
                else
                    continue;
                if(vis[j])
                    continue;
                vis[j]=1;
                break;
            }
            if(i)
                printf(" ");
            printf("%d",cnt);
        }
        puts("");
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值