HDU 3400 Line belt(三分)

Line belt

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3166    Accepted Submission(s): 1232


Problem Description
In a two-dimensional plane there are two line belts, there are two segments AB and CD, lxhgww's speed on AB is P and on CD is Q, he can move with the speed R on other area on the plane.
How long must he take to travel from A to D?
 

Input
The first line is the case number T.
For each case, there are three lines.
The first line, four integers, the coordinates of A and B: Ax Ay Bx By.
The second line , four integers, the coordinates of C and D:Cx Cy Dx Dy.
The third line, three integers, P Q R.
0<= Ax,Ay,Bx,By,Cx,Cy,Dx,Dy<=1000
1<=P,Q,R<=10
 

Output
The minimum time to travel from A to D, round to two decimals.
 

Sample Input
  
  
1 0 0 0 100 100 0 100 100 2 2 1
 

Sample Output
  
  
136.60
这道题是典型的三分,因为从一点到另一条直线上的点的距离的变化不是单调的,而是先减后增,所以需要用嵌套三分。首先三分AB,再依次以mid和mmid为起点,CD上的某点为终点三分即可。


#include<stack>
#include<queue>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#pragma commment(linker,"/STACK: 102400000 102400000")
#define mset0(t) memset(t,0,sizeof(t))
#define lson a,b,l,mid,cur<<1
#define rson a,b,mid+1,r,cur<<1|1
using namespace std;
const double eps=1e-6;

struct point
{
    double x,y;
    point(){}
    point(double x,double y)
    {
        this->x=x;
        this->y=y;
    }
};
const int MAXN=1e5+20;
point A,B,C,D;
int P,Q,R;

double dis(point a,point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

double cd_cal(point a)
{
    point l=C;
    point r=D;
    while(dis(l,r)>eps)
    {
        point mid((l.x+r.x)/2,(l.y+r.y)/2);
        point mmid((mid.x+r.x)/2,(mid.y+r.y)/2);
        if(dis(a,mid)/R+dis(mid,D)/Q>dis(a,mmid)/R+dis(mmid,D)/Q)
            l=mid;
        else
            r=mmid;
    }
    return dis(a,l)/R+dis(l,D)/Q;
}

double cal()
{
    point l=A;
    point r=B;
    while(dis(l,r)>eps)
    {
        point mid((l.x+r.x)/2,(l.y+r.y)/2);
        point mmid((mid.x+r.x)/2,(mid.y+r.y)/2);
        if(dis(A,mid)/P+cd_cal(mid)>dis(A,mmid)/P+cd_cal(mmid))
            l=mid;
        else
            r=mmid;
    }
    return dis(A,l)/P+cd_cal(l);
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    int tcase;
    scanf("%d",&tcase);
    while(tcase--)
    {
        scanf("%lf%lf%lf%lf%lf%lf%lf%lf%d%d%d",&A.x,&A.y,&B.x,&B.y,&C.x,&C.y,&D.x,&D.y,&P,&Q,&R);
        printf("%.2lf\n",cal());
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值