NBUT 1222 English Game(trie树+DP)

3 篇文章 0 订阅

  • [1222] English Game

  • 时间限制: 1000 ms 内存限制: 131072 K
  • 问题描述
  • This English game is a simple English words connection game.


    The rules are as follows: there are N English words in a dictionary, and every word has its own weight v. There is a weight if the corresponding word is used. Now there is a target string X. You have to pick some words in the dictionary, and then connect them to form X. At the same time, the sum weight of the words you picked must be the biggest.








  • 输入
  • There are several test cases. For each test, N (1<=n<=1000) and X (the length of x is not bigger than 10000) are given at first. Then N rows follow. Each row contains a word wi (the length is not bigger than 30) and the weight of it. Every word is composed of lowercases. No two words in the dictionary are the same.
  • 输出
  • For each test case, output the biggest sum weight, if you could not form the string X, output -1.
  • 样例输入
  • 1 aaaa
    a 2
    3 aaa
    a 2
    aa 5
    aaa 6
    4 abc
    a 1
    bc 2
    ab 4
    c 1
    3 abcd
    ab 10
    bc 20
    cd 30
    3 abcd
    cd 100
    abc 1000
    bcd 10000
  • 样例输出
  • 8
    7
    5
    40
    -1

题目大意:

给出一个目标字符串和n个字符串及其对应的权值,求用这些字符串中的1个或多个组成目标字符串的最大权值。


解题思路:
用trie树保存b个字符串及其权值,接下来就是动态规划了。
到达某一点i,遍历trie树找到i+1为第一个字符的字符串,在结束位置j,dp[j]=max(dp[j],dp[i]+val[i+1到j之间的字符串])。除第0位之外,如果dp[i]=0说明没有字符串能够组成0到i之间的字符串,那么就不用查询。


参考代码:

#include<map>
#include<stack>
#include<queue>
#include<cmath>
#include<vector>
#include<cctype>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const double eps=1e-10;
const int INF=0x3f3f3f3f;
const int MAXN=1e4+50;
typedef long long LL;
struct node
{
    node* next[26];
    int val;
    node()
    {
        val=0;
        memset(next,0,sizeof(next));
    }
}*root;

int n,L,dp[MAXN];
char s[MAXN];

void trie_insert(node* start,char* word,int v)
{
    node* now=start;
    int l=strlen(word);
    for(int i=0; i<l; i++)
    {
        int id=word[i]-'a';
        if(now->next[id]==NULL)
            now->next[id]=new node();
        now=now->next[id];
    }
    now->val=v;
}

int trie_query(node* start,int pos)
{
    node* now=start;
    int i;
    for(i=pos+1; i<=L; i++)
    {
        int id=s[i]-'a';
        if(now->next[id]==NULL)
            break;
        now=now->next[id];
        if(now->val)
            dp[i]=max(dp[i],dp[pos]+now->val);
    }
}

int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    while(scanf("%d%s",&n,s+1)!=EOF)
    {
        root=new node();
        L=strlen(s+1);
        memset(dp,0,sizeof(dp));
        for(int i=0; i<n; i++)
        {
            char tmp[MAXN];
            int d;
            scanf("%s%d",tmp,&d);
            trie_insert(root,tmp,d);
        }
        for(int i=0; i<=L; i++)
            if(dp[i]||i==0)//如果dp[i]=0说明没有字符串能够组成0到i之间的字符串,那么就不用查询
                trie_query(root,i);
        printf("%d\n",dp[L]==0?-1:dp[L]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值