HDOJ 1233.还是畅通工程

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28959 Accepted Submission(s): 12951


Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

Output
对每个测试用例,在1行里输出最小的公路总长度。

Sample Input
  
  
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0

Sample Output
  
  
3 5
Hint
Hint
Huge input, scanf is recommended.

Source


最小生成树问题


#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 100001
int father[maxn];
int flag;
void init()
{
    for(int i=0;i<maxn;i++)
        father[i]=i;
}
int Find(int x)
{
    return x==father[x]?x:father[x]=Find(father[x]);
}
void Union(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx==fy)
    {
        flag=0;
    }
    else
    {
        father[fy]=fx;
        flag=1;
    }
}
struct city
{
    int a,b,c;
};
int cmp(city x,city y)
{
    return x.c<y.c;
}
int main()
{
    int m,n,q;
    struct city h[10001];
    while(cin>>m)
    {
        if(!m)  break;
        q=0;
        init();
        n=m*(m-1)/2;
        for(int i=0;i<n;i++)
        {
            cin>>h[i].a>>h[i].b>>h[i].c;
        }
        sort(h,h+n,cmp);
        for(int i=0;i<n;i++)
        {
                Union(h[i].a,h[i].b);
                if(flag)
                    q+=h[i].c;
        }
        cout<<q<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值