POJ 3468 A Simple Problem with Integers

Description:

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

题目大意:

有N个数分别为A1 - An, 下面给出这样几种操作:  1.在给定区间内将每个数字都加上某一特定值   2.查询给定区间的数字和。实现上述操作。

解题思路:

根据题目意思可以看出这道题是线段树的区间增值和区间查询和的模板题, 只要根据题目描述更改模板即可。

代码:

#include <iostream>
#include <fstream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <climits>
#include <cmath>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <map>
#include <set>
#include <iomanip>

using namespace std;

//definition
const int Max = 110010;

int tree[Max];
long long st[Max * 4], add[Max * 4], change[Max * 4];


void Pushup(int o){

    // update parent node & return
    st[o] = st[o << 1] + st[(o << 1) + 1];
}

// deliver node to left and right child
void Pushdown(int o, int len){
    if (add[o]){
        // add update parent to child
        add[o << 1] += add[o];
        add[(o << 1) + 1] += add[o];

        // update node
        st[o << 1] += (add[o] * (len - (len >> 1)));
        st[(o << 1) + 1] += add[o] * (len >> 1);
        add[o] = 0;
    }

}

void Build(int o, int l, int r){

     add[o] = 0;
     if (l == r){
        st[o] = tree[l];
        return;
     }
     int mid = (l + r) >> 1;
     Build(o << 1, l, mid);
     Build((o << 1) + 1, mid + 1, r);

     // perform the sum
     Pushup(o);
}

/// section add & changing

long long Section_query(int o, int l, int r, int ql, int qr){
   if (ql <= l && qr >= r)
       return st[o];
   Pushdown(o, r - l + 1);
   int mid = (l + r) >> 1;
   long long ans = 0;
   if (ql <= mid) ans += Section_query(o << 1, l, mid, ql, qr);
   if (qr > mid) ans += Section_query((o << 1) + 1, mid + 1, r, ql, qr);
   return ans;
}

// last parameter, child, terminal for section, value for add
void Section_update(int o, int l, int r, int tl, int tr, int value){

    // in this section or not
    if (tl <= l && tr >= r){
        add[o] += value;
        st[o] += (long long)value * (r - l + 1);
        return;
    }
    Pushdown(o, r - l + 1);
    int mid = (r + l) >> 1;

    // find the update section
    if (tl <= mid) Section_update(o << 1, l, mid, tl, tr, value);
    if (tr > mid) Section_update((o << 1) + 1, mid + 1, r, tl, tr, value);

    // update parent node
    Pushup(o);
}

int main(){

    // definition
    int n, m;

    scanf("%d%d", &n ,&m);
    for (int i = 1; i <= n; ++i){
        scanf ("%d", &tree[i]);
    }

    // test
    Build(1, 1, n);
    while(m--){
        char c[5];
        scanf("%s",c);
        if (c[0] == 'Q'){
            int left, right;
            scanf("%d %d", &left, &right);
            printf("%I64d\n", Section_query(1, 1, n, left, right));
        }
        else{
            int left, right, val;
            scanf("%d %d %d", &left, &right, &val);
            Section_update(1, 1, n, left, right, val);
        }
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值