Dwarves

Problem description
Once upon a time, there arose a huge discussion among the dwarves in Dwarfland. The government wanted to introduce an identity card for all inhabitants.
Most dwarves accept to be small, but they do not like to be measured. Therefore, the government allowed them to substitute the field “height” in their personal identity card with a field “relative dwarf size”. For producing the ID cards, the dwarves were being interviewed about their relative sizes. For some reason, the government suspects that at least one of the interviewed dwarves must have lied.
Can you help find out if the provided information proves the existence of at least one lying dwarf?

Input
The input consists of: one line with an integer n (1 n 105), where n is the number of statements; n lines describing the relations between the dwarves. Each relation is described by:
? one line with “s1 < s2” or “s1 > s2”, telling whether dwarf s1 is smaller or taller than dwarf s2. s1 and s2 are two different dwarf names.
A dwarf name consists of at most 20 letters from “A” to “Z” and “a” to “z”. A dwarf name does not contain spaces. The number of dwarves does not exceed 104.
Output
Output “impossible” if the statements are not consistent, otherwise output “possible”.
Sample Input
Sample Input 1

3
Dori > Balin
Balin > Kili
Dori < Kili


Sample Input 2 

3
Dori > Balin
Balin > Kili
Dori > Kili
Sample Output
Sample Output 1

impossible

Sample Output 2

possible
Problem Source
GCPC 2016

题意:给定一些字符串S1,S2...Sn,以及它们之间的大小关系,判断关系是否合理.

举个栗子:
         S1<S2,S2<S3,S1<S3  possible
         S1<S2,S2<S3,S1>S3  impossible

题解:先不考虑字符串,把它们全部看成点,大小关系看成有向边,题目就可以转换成一张图

eg1无环,eg2有环
解题的关键就是判断是否存在环,
可以通过dfs()求拓扑排序
(紫书168页的代码可以直接贴)

但这题的重点是hash字符串。。。

每个字符串不超过20个字母组成,并且字母由(a~z,A~z)组成
每个字母会有52种可能,可以将字符串看成52进制的数,转成十进制
进制转换:
     字符串“1010”
      2->10:
      1*2^3+0*2^2+1*2^1+0*2^0
      52->10:
      1*52^3+0*52^2+1*52^1+0*52^0

hash之后就会得到一个很大很大的数用unsigned long long保存(一定会爆,但对这题没啥影响)
然后每个字符串就会得到一个唯一对应的值,因为要保存数据,让它能被塞进数组的下标,这个值要对一个较大的质数取模,模值相对于hash值来说太小,取模之后就可能出现重复的情况,所以要通过链表保存取模后值相同的字符串id.

#include<iostream>
#include<stdio.h>
#include<vector>
#include<string.h>
using namespace std;
typedef unsigned long long ull;
const int maxn=11111;
struct node{
    ull key;
    int id,next;
}buf[maxn];
int n,c[maxn],h[maxn],cnt;
vector<int> e[maxn];
char aa[30],bb[2],cc[30];
bool vis[maxn];
ull gethash(char s[]){
    int len=strlen(s);
    ull ret=0;
    for(int i=0;i<len;i++){
        ret*=52;
        if(s[i]>='a'&&s[i]<='z')
           ret+=s[i]-'a';
        else
           ret+=s[i]-'A'+26;
    }
    return ret;
}
int fnd(ull key){
    for(int i=h[key%maxn];i!=-1;i=buf[i].next)
        if(buf[i].key==key) return buf[i].id;
    return 0;
}
int ins(ull key){
    cnt++;
    buf[cnt].id=cnt,buf[cnt].key=key,buf[cnt].next=h[key%maxn];
    h[key%maxn]=cnt;
    return cnt;
}
bool dfs(int u){
     c[u]=-1;
     for(int i=0;i<e[u].size();i++){
         int v=e[u][i];
         if(c[v]<0) return false;
         else if(!c[v]&&!dfs(v)) return false;
     }
     c[u]=1;
     return true;
}
bool toposort(){
     for(int u=1;u<=cnt;u++)if(!c[u])
         if(!dfs(u)) return false;
     return true;
}
int main(){
    scanf("%d",&n);
    memset(h,-1,sizeof(h));
    for(int i=0;i<n;i++){
        scanf("%s%s%s",aa,bb,cc);
        ull x=gethash(aa);
        ull y=gethash(cc);
        int idx=fnd(x),idy=fnd(y);
        if(!idx) idx=ins(x);
        if(!idy) idy=ins(y);
        if(bb[0]=='<') e[idx].push_back(idy);
        else           e[idy].push_back(idx);
    }
    if(toposort()) printf("possible\n");
    else           printf("impossible\n");
}


《RSMA与速率拆分在有限反馈通信系统中的MMSE基预编码实现》 本文将深入探讨RSMA(Rate Splitting Multiple Access)技术在有限反馈通信系统中的应用,特别是通过MMSE(Minimum Mean Square Error)基预编码进行的实现。速率拆分是现代多用户通信系统中一种重要的信号处理策略,它能够提升系统的频谱效率和鲁棒性,特别是在资源受限和信道条件不理想的环境中。RSMA的核心思想是将用户的数据流分割成公共和私有信息两部分,公共信息可以被多个接收器解码,而私有信息仅由特定的接收器解码。这种方式允许系统在用户间共享信道资源,同时保证了每个用户的个性化服务。 在有限反馈通信系统中,由于信道状态信息(CSI)的获取通常是有限且不精确的,因此选择合适的预编码技术至关重要。MMSE预编码是一种优化策略,其目标是在考虑信道噪声和干扰的情况下最小化期望平方误差。在RSMA中,MMSE预编码用于在发射端对数据流进行处理,以减少接收端的干扰,提高解码性能。 以下代码研究RSMA与MMSE预编码的结合以观察到如何在实际系统中应用RSMA的速率拆分策略,并结合有限的反馈信息设计有效的预编码矩阵。关键步骤包括: 1. **信道模型的建立**:模拟多用户MIMO环境,考虑不同用户之间的信道条件差异。 2. **信道反馈机制**:设计有限反馈方案,用户向基站发送关于信道状态的简化的反馈信息。 3. **MMSE预编码矩阵计算**:根据接收到的有限反馈信息,计算出能够最小化期望平方误差的预编码矩阵。 4. **速率拆分**:将每个用户的传输信息划分为公共和私有两部分。 5. **信号发射与接收**:使用预编码矩阵对信号进行处理,然后在接收端进行解码。 6. **性能评估**:分析系统吞吐量、误码率等性能指标,对比不同策略的效果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值