hdu_4772 关于矩阵旋转问题的全面考察

Zhuge Liang’s Password

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3166 Accepted Submission(s): 1867

Problem Description

  In the ancient three kingdom period, Zhuge Liang was the most famous and smart military leader. His enemy was Sima Yi, the military leader of Kingdom Wei. Sima Yi always looked stupid when fighting against Zhuge Liang. But it was Sima Yi who laughed to the end.
  Zhuge Liang had led his army across the mountain Qi to attack Kingdom Wei for six times, which all failed. Because of the long journey, the food supply was a big problem. Zhuge Liang invented a kind of bull-like or horse-like robot called “Wooden Bull & Floating Horse”(in abbreviation, WBFH) to carry food for the army. Every WBFH had a password lock. A WBFH would move if and only if the soldier entered the password. Zhuge Liang was always worrying about everything and always did trivial things by himself. Since Ma Su lost Jieting and was killed by him, he didn’t trust anyone’s IQ any more. He thought the soldiers might forget the password of WBFHs. So he made two password cards for each WBFH. If the soldier operating a WBFH forgot the password or got killed, the password still could be regained by those two password cards.
  Once, Sima Yi defeated Zhuge Liang again, and got many WBFHs in the battle field. But he didn’t know the passwords. Ma Su’s son betrayed Zhuge Liang and came to Sima Yi. He told Sima Yi the way to figure out the password by two cards.He said to Sima Yi:
  “A password card is a square grid consisting of N×N cells.In each cell,there is a number. Two password cards are of the same size. If you overlap them, you get two numbers in each cell. Those two numbers in a cell may be the same or not the same. You can turn a card by 0 degree, 90 degrees, 180 degrees, or 270 degrees, and then overlap it on another. But flipping is not allowed. The maximum amount of cells which contains two equal numbers after overlapping, is the password. Please note that the two cards must be totally overlapped. You can’t only overlap a part of them.”
  Now you should find a way to figure out the password for each WBFH as quickly as possible.
  

Input

  There are several test cases.
  In each test case:
  The first line contains a integer N, meaning that the password card is a N×N grid(0

Output

  For each test case, print the password.

Sample Input

2
1 2
3 4
5 6
7 8
2
10 20
30 13
90 10
13 21
0

Sample Output

0
2

这个题完善地说明了矩阵旋转的三个方向,一开始博主WA的原因是因为忘记了和自己原来比较。。。。
话说50%的AC率实在是有点低。。。。

#include<iostream>
#include<cstring>
#include<climits>
using namespace std;
int arr[102][102];
int indeg[102];
int n;
int inf = INT_MAX;
int i,j,k;
int find(int trr[])
{
   int tmp=n/2;
   for(i=1;i<=n;i++)
   {
      if(trr[i]<trr[tmp])
      {
        tmp = i;
      }
   }
   return tmp;
} 
int main()
{
    while(cin>>n)
{
    int a;
    memset(arr,0,sizeof(arr));
    memset(indeg,0,sizeof(indeg));
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=n;j++)
        {
            cin>>a;
            if(a==0)
            {
                break;
            }
            arr[i][a]=1;
            indeg[a]++;
        }
    }
    int ans[102];
    for(k=1;k<=n;k++)
    {
        ans[k]=find(indeg);
        indeg[ans[k]]=inf;

            for(j=1;j<=n;j++)
           {
              if(arr[ans[k]][j]==1)
              {
                   indeg[j]--;
              }
           }
    }
    for(i=1;i<n;i++)
    {
        cout<<ans[i]<<" ";
    }
     cout<<ans[n]<<endl;
}

} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值