数据结构实验之链表四:有序链表的归并

数据结构实验之链表四:有序链表的归并

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Sample Input

6 5
1 23 26 45 66 99
14 21 28 50 100

Sample Output

1 14 21 23 26 28 45 50 66 99 100

代码


#include <stdio.h>
#include <stdlib.h>
struct node {
    int data;
    struct node* next;
};


void create(struct node*head,int n)
{
    struct node *tail,*p;

    tail=head;

    for(int i=1;i<=n;i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        p->next=NULL;
        scanf("%d",&p->data);

        tail->next=p;
        tail=p;
    }

}

void hebing(struct node*head,struct node *h1,struct node *h2)
{

    struct node *p1,*p2,*tail;

    tail=head;
    p1=h1->next;
    p2=h2->next;


    while(p1&&p2)
    {
        if(p1->data<p2->data)
        {
            tail->next=p1;
            tail=p1;
            p1=p1->next;
        }
        else
        {
            tail->next=p2;
            tail=p2;
            p2=p2->next;
        }
    }
    if(p1)
        tail->next=p1;
    else
        tail->next=p2;
}

void show(struct node *head)
{

    head=head->next;
    while(head)
    {
        if(head->next!=NULL)
            printf("%d ",head->data);
        else
            printf("%d\n",head->data);

        head=head->next;
    }
}
int main()
{
    int m,n;
    struct node* h1,*h2,*head;

    scanf("%d %d",&m,&n);
    h1=(struct node*)malloc(sizeof(struct node));
    h2=(struct node*)malloc(sizeof(struct node));
    head=(struct node*)malloc(sizeof(struct node));

    create(h1,m);
    create(h2,n);
    //show(h1);
    hebing(head,h1,h2);
    show(head);


    return 0;
}

3.总结

该题的难点就是在关于归并问题上,其实就是几行代码,要清楚,我们一直对归并后的head不断添加元素,我们并未改变两个链表之后的值,而tail指向最后一个相关元素,当再遇到新的元素之后,tail->next=p1 or p2,这就改变了上次链表的值,这是我们已经遍历过的,自然不会破坏前面的链表,当这个思路明确之后,整个链表的书写就很简单了!

while(p1&&p2)
    {
        if(p1->data<p2->data)
        {
            tail->next=p1;
            tail=p1;
            p1=p1->next;
        }
        else
        {
            tail->next=p2;
            tail=p2;
            p2=p2->next;
        }
    }
    if(p1)
        tail->next=p1;
    else
        tail->next=p2;
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值