hdu 5387

Clock

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 311    Accepted Submission(s): 212


Problem Description
Give a time.(hh:mm:ss),you should answer the angle between any two of the minute.hour.second hand
Notice that the answer must be not more 180 and not less than 0
 

Input
There are  T (1T104)  test cases
for each case,one line include the time

0hh<24 , 0mm<60 , 0ss<60
 

Output
for each case,output there real number like A/B.(A and B are coprime).if it's an integer then just print it.describe the angle between hour and minute,hour and second hand,minute and second hand.
 

Sample Input
  
  
4 00:00:00 06:00:00 12:54:55 04:40:00
 

Sample Output
  
  
0 0 0 180 180 0 1391/24 1379/24 1/2 100 140 120
Hint
每行输出数据末尾均应带有空格
 

题目大意:给出时间h: m: s  ,求出三个指针的角度

思       路 :首先确认的一点是s转一圈走360下,跳一下就是1度    时针的角度要加上分针和秒针对应的角度 分针也是

                    因此需要算出三个针的角度再互相减去,同时保证数据在180 度以内 

代码如下:

/*踏实!!努力!!*/
#include<iostream>
#include<algorithm>
#include<string>
#include<sstream>
#include<set>
#include<vector>
#include<stack>
#include<map>
#include<queue>
#include<deque>
#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<ctime>
#include<cctype>
#include<functional>
using namespace std;
int gcd(int a,int b)
{
    if(b==0)
        return a;
    return gcd(b,a%b);
}
void work(int t1,int t2)
{
    int t=abs(t1-t2);
    int k=120;
    if(t>180*k) t=360*k-t;
    int g=gcd(t,k);

    if(k/g==1) printf("%d ",t/g);
    else printf("%d/%d ",t/g,k/g);
}
int main()
{
    int t,h,m,s;
    scanf("%d",&t);
    while(t--){
        scanf("%d:%d:%d",&h,&m,&s);
        int hh,mm,ss;
        if(h>=12) h-=12;
        //先化为整数 全部乘以120
        ss=s*720;  
        mm=m*720+s*12;
        hh=h*3600+m*60+s;
        work(hh,mm);
        work(hh,ss);
        work(mm,ss);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值