poj 2488 A Knight's Journey(dfs+记录路径)

poj 2488 A Knight’s Journey(dfs+记录路径)
Time Limit: 1000ms Memory Limit: 65536kB

Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
这里写图片描述
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …

Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source
TUD Programming Contest 2005, Darmstadt, Germany


很基础dfs的题目,注意几个问题:一是答案要字典序最小(如果不认识lexicographically这个单词,可以看样例输出猜测),那么在走步时候要注意次序,步长数组dir里面顺序要安排得当保证搜索到的字典序最小,同时,由于要求字典序不必要贪心或A*算法启发式搜索优化。而是注意输入的是p*q<=26,所以遇到这种问题最好数组开一维以防浪费空间(当然本题主要瓶颈在搜索不再这么点空间上,如果其他题目给的条件是x+y<=a,或x*y<=a类型,开数组可以放入一维内部自己编码),三是行列不要弄错。


Accepted    136kB   14ms    1266 B  G++
#include<stdio.h>

const int dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};

int cases,m,n; 
bool finish;
int former[26];

inline int pos(int i,int j)
{
    return i*m+j;
} 

inline bool in(int i,int j)
{
    return i>=0 && i<n && j>=0 && j<m; 
} 

void print(int t)
{
    if (former[t]!=-2)
        print(former[t]);
    printf("%c%c",'A'+t/m,'1'+t%m);
    return; 
}

void dfs(int now,int i,int j)
{
    /*
    printf("%d %c%c:",now,i+'A',j+'1');
    for (int t=0;t<m*n;t++)
        printf("%3d",former[t]);
    printf("\n");
    */
    if (now==m*n)
    {
        print(pos(i,j));
        printf("\n");
        finish=true;
        return;
    }
    if (finish)
        return;
    int i1,j1;
    for (int d=0;d<8;d++)
    {
        i1=i+dir[d][0];
        j1=j+dir[d][1];
        if (in(i1,j1) && (former[pos(i1,j1)]==-1))
        {
            former[pos(i1,j1)]=pos(i,j);
            dfs(now+1,i1,j1);
            former[pos(i1,j1)]=-1;
        }
    }
    return;
}

int main()
{
    scanf("%d",&cases);
    for (int scenario=1;scenario<=cases;scenario++)
    { 
        if (scenario>1)
            printf("\n");
        printf("Scenario #%d:\n",scenario);
        finish=false;
        scanf("%d%d",&m,&n);
        for (int i=0;i<n;i++)
            for (int j=0;j<m;j++)
                if (!finish)
                {
                    for (int t=0;t<n*m;t++)
                        former[t]=-1;
                    former[pos(i,j)]=-2;
                    dfs(1,i,j);
                }
        if (!finish)
            printf("impossible\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值