POJ2993 -- Emag eht htiw Em Pleh(大模拟)

Emag eht htiw Em Pleh

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 4639Accepted: 2928

Description

This problem is a reverse case of the problem 2996
. You are given the output of the problem H and your task is to find the corresponding input.

Input

according to output of problem 2996.

Output

according to input of problem 2996.

Sample Input

White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6

Sample Output

+---+---+---+---+---+---+---+---+
|.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
+---+---+---+---+---+---+---+---+
|:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
+---+---+---+---+---+---+---+---+
|...|:::|.n.|:::|...|:::|...|:p:|
+---+---+---+---+---+---+---+---+
|:::|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|...|:::|...|:::|.P.|:::|...|:::|
+---+---+---+---+---+---+---+---+
|:P:|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
+---+---+---+---+---+---+---+---+
|:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
+---+---+---+---+---+---+---+---+

既然前面把2996给做了,就顺便把它的sister题2993也做了,AC代码:

#include<iostream>
#include<string>
#include<cctype>
using namespace std;
const int maxn = 100;
char arr[maxn][maxn];
void func(bool f, string &s)//1表示大写 
{
	int len = s.length();
	for (int i = 0; i < len; i++)
	{
		string tmp;
		if (isupper(s[i]))
		{
			tmp = s.substr(i, 3);
			int x = 17 - (tmp[2] - '0') * 2, y = (tmp[1] - 'a') * 4 + 2;
			arr[x][y] = f ? tmp[0] : towlower(tmp[0]);
			i += 3;
		}
		else
		{
			tmp = s.substr(i, 2);
			int x = 17 - (tmp[1] - '0') * 2, y = (tmp[0] - 'a') * 4 + 2;
			arr[x][y] = f ? 'P' : 'p';
			i += 2;
		}
	}
}
int main()
{
	ios_base::sync_with_stdio(0), cin.tie(0);
	for (int i = 0; i < 17; i++)
	{
		for (int j = 0; j < 33; j++)
		{
			if (i % 2 == 0)
			{
				if (j % 4 == 0)arr[i][j] = '+';
				else arr[i][j] = '-';
			}
			else if (j % 4 == 0)arr[i][j] = '|';
			else
			{
				int x = i / 2, y = j / 4;
				if ((x + y) % 2)arr[i][j] = ':';
				else arr[i][j] = '.';
			}
		}
	}
	string a, b, n, m;
	cin >> n >> a >> m >> b;
	func(1, a);
	func(0, b);
	for (int i = 0; i < 17; i++)
	{
		for (int j = 0; j < 33; j++)
		{
			cout << arr[i][j];
		}
		cout << "\n";
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值