PAT1003

1003. Emergency (25)

题目:

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2

1 2 1 5 3

0 1 1

0 2 2

0 3 1

1 2 1

2 4 1

3 4 1

Sample Output

2  4

题目连接

题目描述:

  每个城市有一定数目的救援队,给你一张图,问从起点到终点最短距离的条数以及最大救援队伍数目。

分析

一个无向图中,已知边权和点权,求最短路径的条数,当有多条最短路径时,输出点权和最大的值,用 Dijkstra 算法就能解决。

代码



    #include <iostream>
    #include <cstring>
    using namespace std;
    const int maxn = 500 + 5;
    const int INF = 100000000;
    int G[maxn][maxn];          //邻接矩阵
    int weight[maxn];           //记录每个点的点权
    int w[maxn];                //最大点权值
    int dis[maxn];              //最小距离
    int num[maxn];              //最短距离条数
    bool visit[maxn] = {false};
    int n;

    void Dijkstra(int v){               //起始顶点 v
        for(int i = 0;i < maxn;i++)
            dis[i] = INF;
        memset(num,0,sizeof(num));
        memset(w,0,sizeof(w));

        dis[v] = 0;
        w[v] = weight[v];
        num[v] = 1;

        for(int i = 0;i < n;i++){
            int u = -1,min = INF;
            for(int j = 0;j < n;j++){
                if(visit[j] == false && dis[j] < min){
                    u = j;
                    min = dis[j];
                }
            }

            if(u == -1) return;
            visit[u] = true;

            for(int j = 0;j < n;j++){
                if(visit[j] == false && G[u][j] != INF){
                    if(dis[j] > dis[u] + G[u][j]){      //如果能找到更短的路径就更新 dis 数组
                        dis[j] = dis[u] + G[u][j];
                        w[j] = w[u] + weight[j];
                        num[j] = num[u];
                    }else if(dis[j] == dis[u] + G[u][j]){   //找到一条长度相等的路径
                        if(w[u] + weight[j] > w[j]){        //保存较大的点权值
                            w[j] = w[u] + weight[j];
                        }
                        num[j] += num[u];                   //最短路径条数与点权值没有关系,必须写在外面
                    }
                }
            }

        }
    }
    int main(void){
        ios::sync_with_stdio(false);

        for(int i = 0;i < maxn;i++)     //初始化图
            for(int j = 0;j < maxn;j++)
                G[i][j] = INF;

        int m,c1,c2;
        cin>>n>>m>>c1>>c2;

        for(int i = 0;i < n;i++)
            cin>>weight[i];

        for(int i = 0;i < m;i++){
            int v1,v2,value;
            cin>>v1>>v2>>value;
            G[v1][v2] = value;
            G[v2][v1] = value;
        }

        Dijkstra(c1);

        cout<<num[c2]<<" "<<w[c2]<<endl;
        return 0;
    }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值