PAT1015

1015. Reversible Primes (20)

题目:

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output

For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.

Sample Input

73 10

23 2

23 10

-2

Sample Output

Yes

Yes

No

题目连接

题目描述:

  给你一个 N 和 D,判断 N 是否是素数,将 N 转换成 D 进制数然后翻转,判断这个数是不是素数,如果都是素数则输出 “Yes” 否则输出 “No”。

分析

按照题目要求,分步操作即可:

  1. 将 N 转化为 D进制数。
  2. 将转化的数进行翻转,再转化成十进制数。
  3. 判断 N 和转换后的数是否是素数,如果都是素数则输出 “Yes” 否则输出 “No”.

注意:1 不是质数,除了 2 以外所有偶数都不是质数。

代码


    #include <iostream>
    #include <stack>
    #include <cmath>
    using namespace std;
    const int maxn = 100000 + 5;
    bool isPrime(int n){        //判断是否是素数,注意:1 不是质数;2 虽然是一个偶数,但是 2 是一个质数
        if(n < 2)   return false;
        for(int i = 2;i < n;i++){
            if(n % i == 0){
                return false;
            }
        }
        return true;
    }
    int getReverse(int n,int k){        //将 n 转化成 k 进制数,翻转,再转化为十进制数
        stack<int> s;
        while(n != 0){                  //转化为 k 进制数,保存到栈中
            s.push(n%k);
            n = n/k;
        }

        int cnt = 0,sum = 0;
        while(s.size()){                //转化为十进制数
            sum += s.top()*pow(k,cnt);
            s.pop();
            cnt++;
        }

        return sum;
    }
    int main(void){
        ios::sync_with_stdio(false);

        int n,d;
        while(cin>>n){
            if(n < 0)
                break;
            cin>>d;

            int tempReverse = getReverse(n,d);
            if(isPrime(n) && isPrime(tempReverse)){
                cout<<"Yes"<<endl;
            }else{
                cout<<"No"<<endl;
            }
        }

        return 0;
    }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值