BUPT Summer Journey #test9 A

 

A. diffsum 2014新生暑假个人排位赛09

时间限制 1000 ms     内存限制 65536 KB    

题目描述

You are givin an array of integers, and you are to figure out the sum of differences between each pair of integers belonging to the array. SEE THE HINT FOR MORE INFORMATION.

输入格式

There are multiple test cases. The first line contains an integer n(n<=1e5), size of the array. The second line contains n integers, ai(|ai|<=100000), the array.

输出格式

For each case, output one line, the answer.

输入样例

4
1 1 2 2

输出样例

4

hint
for the test case the answer is abs(1-1)+abs(1-2)+abs(1-2)+abs(1-2)+abs(1-2)+abs(2-2)=4.

思路:先排序使其具有大小关系。然后进行一轮O(n)的递推即可。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#define maxn 200005
//#define LOCAL
using namespace std;
int n,a[maxn];
long long ans;
int main()
{
    #ifdef LOCAL
    freopen("input.txt","r",stdin);
    #endif // LOCAL
    while(scanf("%d",&n)==1)
    {
        long long sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);sum+=a[i];
        }
        sort(a+1,a+1+n);
        sum=sum-(long long)n*(long long)a[1];
        ans=sum;
        //long long ans=sum;
        //printf("%I64d\n",ans);
        int j=1;
        for(int i=n-1;i>=2;i--)
        {
            sum=sum+(long long)i*(long long)(a[j]-a[j+1]);
            ans+=sum;
            j++;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值