6-26 统计专业人数 (15分)

本题要求实现一个函数,统计学生学号链表中专业为计算机的学生人数。链表结点定义如下:

struct ListNode {
    char code[8];
    struct ListNode *next;
};

 

这里学生的学号共7位数字,其中第2、3位是专业编号。计算机专业的编号为02。

函数接口定义:

int countcs( struct ListNode *head );

 

其中head是用户传入的学生学号链表的头指针;函数countcs统计并返回head链表中专业为计算机的学生人数。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct ListNode {
    char code[8];
    struct ListNode *next;
};

struct ListNode *createlist(); /*裁判实现,细节不表*/
int countcs( struct ListNode *head );

int main()
{
    struct ListNode  *head;

    head = createlist();
    printf("%d\n", countcs(head));
	
    return 0;
}

/* 你的代码将被嵌在这里 */

 

输入样例:

1021202
2022310
8102134
1030912
3110203
4021205
#

 

输出样例:

3

 

作者: 张泳

单位: 浙江大学城市学院

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB


编译器 (1)

C (gcc)

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct ListNode {
    char code[8];
    struct ListNode *next;
};

//struct ListNode *createlist(); /*裁判实现,细节不表*/
struct ListNode *createlist(struct ListNode *head, char temp[]);
int countcs( struct ListNode *head );

int main()
{
    struct ListNode  *head;
//
    head = NULL;
    char temp[8]={};
    do{
    	scanf("%s",temp);
    	if(temp[0] != '#'){
    		head = createlist(head, temp);
		}
	}while(temp[0] != '#');
//	head = createlist();
    printf("%d\n", countcs(head));
	
    return 0;
}
/* 空参的我写不来,写了个有参的。为保证运行,将原题做了相应修改。 */ 
struct ListNode *createlist(struct ListNode *head, char temp[])
{
	//add to linked-list
	struct ListNode *p;
	p = (struct ListNode*)malloc(sizeof(struct ListNode));
	strcpy(p->code, temp);
	p->next = NULL;
	//find the last
	struct ListNode *last = head;
	if(last){
		if(last->next){
			last = last->next;
		}
		//attach
		last->next = p;
	}else{
		head = p;
	}
	return head;
}
/* 你的代码将被嵌在这里 */
int countcs( struct ListNode *head )
{
	int cnt=0;
	struct ListNode *p;
	p = head;
	while(p){
		if(p->code[1]=='0' && p->code[2]=='2')
			cnt++;
		p = p->next;
	}
	return cnt;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

涛声依旧很冷

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值