E - Easy Summation

You are encountered with a traditional problem concerning the sums of powers. 
Given two integers  n n and  k k. Let  f(i)=ik f(i)=ik, please evaluate the sum  f(1)+f(2)+...+f(n) f(1)+f(2)+...+f(n). The problem is simple as it looks, apart from the value of  n nin this question is quite large. 
Can you figure the answer out? Since the answer may be too large, please output the answer modulo  109+7 109+7.
Input
The first line of the input contains an integer  T(1T20) T(1≤T≤20), denoting the number of test cases. 
Each of the following  T T lines contains two integers  n(1n10000) n(1≤n≤10000) and  k(0k5) k(0≤k≤5)
Output
For each test case, print a single line containing an integer modulo  109+7 109+7.
Sample Input
3
2 5
4 2
4 1
Sample Output
33
30

10

这个题的数据量是很大的,因此每求一次a^b,都要进行取模,所以我们把pow()函数在这儿重新写 一次,同时,最后的输出结果也要取模。

#include <iostream>
#include<cstdio>
#include<cmath>
using namespace std;
const int N=1000000000+7;
long long pow1(int a,int b)
{
   long long p=1;
   for(int i=1;i<=b;i++)
   {
       p*=a;
       p%=N;
   }
   return p;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
      long long a,b,sum=0;
      scanf("%lld%lld",&a,&b);
      for(int i=1;i<=a;i++)
        sum+=pow1(i,b);
      printf("%lld\n",sum%N);
    }
    return 0;
}
    
    











































  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值