Balloon Comes!

Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.  
Is it very easy?  
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
 

Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.  
 

Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
 

Sample Input
 
 
4 + 1 2 - 1 2 * 1 2 / 1 2
 

Sample Output
 
 
3 -1 2 0.50
 

Author
lcy
 WA了几次发现忽略了一个问题,没考虑a/b(a=b)的情况。这是应该输出整型,而不是浮点型。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int main()
{
    int T;
	scanf("%d",&T);
	while(T--)
	{
		char c;
		int a,b;
		cin>>c>>a>>b;
		    if(c=='+')
		printf("%d\n",a+b);
			if(c=='-')
		printf("%d\n",a-b);
			if(c=='*')
		printf("%d\n",a*b);
			if(c=='/')
			{
				if(a%b==0)
				{
					printf("%d\n",a/b);
				}
				else
				printf("%.2f\n",a*1.0/b);
			}		
	} 
	return 0;   
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值