Unique Ascending Array

Description

Given an array of integers A[N], you are asked to decide the shortest array of integers B[M], such that the following two conditions hold.

  • For all integers 0 <= i < N, there exists an integer 0 <= j < M, such that A[i] == B[j]
  • For all integers 0 =< i < j < M, we have B[i] < B[j]

Notice that for each array A[] a unique array B[] exists.

 

Input

 

The input consists of several test cases. For each test case, an integer N (1 <= N <= 100) is given, followed by N integers A[0], A[1], ..., A[N - 1] in a line. A line containing only a zero indicates the end of input.

 

Output

 

For each test case in the input, output the array B in one line. There should be exactly one space between the numbers, and there should be no initial or trailing spaces.

 

Sample Input

 

8 1 2 3 4 5 6 7 8
8 8 7 6 5 4 3 2 1
8 1 3 2 3 1 2 3 1
0

 

Sample Output

 

1 2 3 4 5 6 7 8
1 2 3 4 5 6 7 8
1 2 3

#include<iostream>
#include<cstdio>
#include<set>
using namespace std;
int main()
{
	int n;
	
	while(cin>>n && n)
	{
	     set<int> s;
	     set<int>::iterator it;
	     int x;
	     int flag=1;
		for(int i=0;i<n;i++)
		{
			cin>>x;
			s.insert(x);
		}
		for ( it = s.begin(); it != s.end(); it++)    
        {
        	if(flag)
        	{
        		cout << *it;
        		flag=0;
			}
			else
            cout << " "<<*it;  
        }  
        cout<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值