08-2. The World's Richest

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None". Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50
Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

分析:这道题目意思就是说给出你一些有钱人的信息,然后要你在它给的年龄范围内求出前M名,并将他们输出。题目不难,采用c++STL的话很容易就能做出来,但是我不得不吐槽这道题目,坑,天坑,坑在哪里呢?坑在时间,如果你就用我开始说的思路做下去,绝对有测试点会超时,所以,一直在想该如何去优化这个代码?

仔细阅读题目,你会发现这样一个信息:M<=100,这个信息表明的意思就是,当某个年龄出现的次数大于一百的时候可以过滤掉

可是我后来又试出了一种,那就是在你输出处理时,那个循环有必要循环N次吗?对,是没必要的,你只需要输出M个就好了,何必去循环那么多次。测试也是通过了,不过比前一种方式时间长一点。我下面的代码是第二种,好理解。


源码:

#include<iostream>
#include <cstdio> 
#include<algorithm>
#include<vector>
#include<string>

using namespace std;

//亿万富翁结点
struct billionaires{
	string name;
	int age;
	int net_worth;
	billionaires(string n, int a, int nw):name(n), age(a), net_worth(nw){}
	void output(){
		cout << name;
		printf(" %d %d\n", age, net_worth);
	}
};


//比较函数
bool compare(const billionaires &m1, const billionaires &m2){
	if (m1.net_worth != m2.net_worth){
		return m1.net_worth > m2.net_worth;
	}
	else{
		if (m1.age != m2.age){
			return m1.age < m2.age;
		}
		else{
			return m1.name < m2.name;
		}
	}
}

int main()
{
	int N, K;
	scanf("%d %d", &N, &K);          // 第一行输入
	vector<billionaires> vec;
	for (int i = 0; i < N; i++){		//输入信息存储
		string name;	
		cin >> name;
		int age, net_worth;
		scanf("%d %d",&age, &net_worth);
		vec.push_back(billionaires(name, age, net_worth));
	}
	//排序
		sort(vec.begin(), vec.end(), compare);
	for (int i = 0; i < K; i++){			//k个case
		int M, Amin, Amax;
		scanf("%d %d %d", &M, &Amin, &Amax);	//输入case信息
		printf("Case #%d:\n", i + 1);		
		bool flag = false;	//判断是否有位于此区间的数据
		for (int k = 0,count = 0;k<N && count<M; k++){		
			if (vec[k].age >= Amin && vec[k].age<=Amax){
				vec[k].output();
				count++;
				flag = true;		//说明有信息
			}		
		}
		if (!flag){					//没有在此范围内的数据
			printf("None\n");
			continue;
		}
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值