欧拉回路输出路径 POJ - 1041

John's trip
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8977 Accepted: 3010 Special Judge

Description

Little Johnny has got a new car. He decided to drive around the town to visit his friends. Johnny wanted to visit all his friends, but there was many of them. In each street he had one friend. He started thinking how to make his trip as short as possible. Very soon he realized that the best way to do it was to travel through each street of town only once. Naturally, he wanted to finish his trip at the same place he started, at his parents' house.

The streets in Johnny's town were named by integer numbers from 1 to n, n < 1995. The junctions were independently named by integer numbers from 1 to m, m <= 44. No junction connects more than 44 streets. All junctions in the town had different numbers. Each street was connecting exactly two junctions. No two streets in the town had the same number. He immediately started to plan his round trip. If there was more than one such round trip, he would have chosen the one which, when written down as a sequence of street numbers is lexicographically the smallest. But Johnny was not able to find even one such round trip.

Help Johnny and write a program which finds the desired shortest round trip. If the round trip does not exist the program should write a message. Assume that Johnny lives at the junction ending the street appears first in the input with smaller number. All streets in the town are two way. There exists a way from each street to another street in the town. The streets in the town are very narrow and there is no possibility to turn back the car once he is in the street

Input

Input file consists of several blocks. Each block describes one town. Each line in the block contains three integers x; y; z, where x > 0 and y > 0 are the numbers of junctions which are connected by the street number z. The end of the block is marked by the line containing x = y = 0. At the end of the input file there is an empty block, x = y = 0.

Output

Output one line of each block contains the sequence of street numbers (single members of the sequence are separated by space) describing Johnny's round trip. If the round trip cannot be found the corresponding output block contains the message "Round trip does not exist."

Sample Input

1 2 1
2 3 2
3 1 6
1 2 5
2 3 3
3 1 4
0 0
1 2 1
2 3 2
1 3 3
2 4 4
0 0
0 0

Sample Output

1 2 3 5 4 6 
Round trip does not exist.

题意:给x, y, z表示路口x与y通过街道联通,要求这些路口是否能形成欧拉回路,是的话输出路径。

输出路径这个不知道怎么搞,网上看了下用递归解决。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <cmath>
#include <cstdlib>
// mapp[x][z]=y 表示x通过z与y联通, deg[x]为度数
using namespace std;
int vist[2000], mapp[2000][2000], deg[2000], path[2000];
int m, cnt;

void dfs(int s)
{
    for(int i = 1; i <= m; i++) {
        if(!vist[i] && mapp[s][i]) {
            vist[i] = 1;
            dfs(mapp[s][i]);
            path[cnt++] = i;
        }
    }
}

int main()
{
    int x, y, z, n, s;
    while(~scanf("%d%d", &x, &y) && (x+y)) {
        scanf("%d", &z);
        n = max(x, y);
        m = z;
        s = min(x, y);
        memset(vist, 0, sizeof(vist));
        memset(deg, 0, sizeof(deg));
        memset(mapp, 0, sizeof(mapp));
        memset(path, 0, sizeof(path));
        mapp[x][z] = y;
        mapp[y][z] = x;
        deg[x]++;
        deg[y]++;
        while(~scanf("%d%d", &x, &y) && (x+y)) {
            scanf("%d", &z);
            mapp[x][z] = y;
            mapp[y][z] = x;
            deg[x]++;
            deg[y]++;
            m = max(m, z);
            n = max(n, max(x, y));
            s = min(s, min(x, y));
        }
        bool flag = false;
        for(int i = 1; i <= n; i++) {
            if(deg[i]%2 == 1) {
                printf("Round trip does not exist.\n");
                flag = true;
                break;
            }
        }
        if(flag) continue;
        cnt = 0;
        dfs(s);
        for(int i = cnt-1; i >= 0; i--) {
            printf("%d", path[i]);
            if(i != 0) printf(" ");
            else printf("\n");
        }
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值