ZOJ-1610 线段树区间更新

Count the Colors

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2

1 1

题意:有[0,8000]长的线段,每次给出l, r, col,表示在左端点l到右端点r的区间染成颜色col,后染的颜色会覆盖掉之前的颜色,最有输出每种颜色各有多少段区间。

解法:线段树区间更新,节点表示区间颜色,update(l, r, c)表示第l段到r段更新。如

1    3    2

是从左端点1到右端点3染成颜色2,对应区间应该是[2, 3](将单位线段表示为点,染的是第二段和第三段,可以画图感受以下),所以更新是要写成update(l+1, r, c)。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>

using namespace std;
struct nodee {
    int l, r;
} q[10010];
int ans, x[10010<<4], col[10010<<4];
bool hashh[10010];

void pushdown(int rt)
{
    if(col[rt] != -1) {
        col[rt<<1] = col[rt<<1|1] = col[rt];
        col[rt] = -1;
    }
    return ;
}

void update(int L, int R, int c, int l, int r, int rt)
{
    if(L <= l && r <= R) {
        col[rt] = c;
        return ;
    }
    pushdown(rt);
    int mid = (l+r) >> 1;
    if(L <= mid) update(L, R, c, l, mid, rt<<1);
    if(R > mid) update(L, R, c, mid+1, r, rt<<1|1);
}

void query(int l, int r, int rt)
{
    if(col[rt] != -1) {
        if(!hashh[col[rt]]) ans++;
        hashh[col[rt]] = true;
        return ;
    }
    if(l == r) return ;
    int mid = (l+r) >> 1;
    query(l, mid, rt<<1);
    query(mid+1, r, rt<<1|1);
}

int main()
{
    int T, n;
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        int cnt = 0;
        for(int i = 0; i < n; i++) {
            scanf("%d%d", &q[i].l, &q[i].r);
            x[cnt++] = q[i].l, x[cnt++] = q[i].r;
        }
        sort(x, x+cnt);
        int m = 1;
        for(int i = 1;i < cnt; i++) if(x[i] != x[i-1]) x[m++] = x[i];
        memset(col, -1, sizeof(col));
        for(int i = 0; i < n; i++) {
            int l = lower_bound(x, x+m, q[i].l) - x;
            int r = lower_bound(x, x+m, q[i].r) - x;
            update(l, r, i, 0, m, 1);
        }
        memset(hashh, false, sizeof(hashh));
        ans = 0;
        query(0, m, 1);
        printf("%d\n", ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值