第一次编程作业



01-复杂度1 最大子列和问题   (20分)

给定KKK个整数组成的序列{N1N_1N1,N2N_2N2, ..., NKN_KNK },“连续子列”被定义为{ NiN_iNi,Ni+1N_{i+1}Ni+1, ..., NjN_jNj },其中 1≤i≤j≤K1 \le i \le j \le K1ijK。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{ -2, 11, -4, 13, -5, -2 },其连续子列{ 11, -4, 13 }有最大的和20。现要求你编写程序,计算给定整数序列的最大子列和。

本题旨在测试各种不同的算法在各种数据情况下的表现。各组测试数据特点如下:

  • 数据1:与样例等价,测试基本正确性;
  • 数据2:102个随机整数;
  • 数据3:103个随机整数;
  • 数据4:104个随机整数;
  • 数据5:105个随机整数;

输入格式:

输入第1行给出正整数KKK (≤100000\le 100000100000);第2行给出KKK个整数,其间以空格分隔。

输出格式:

在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出0。

输入样例:

6
-2 11 -4 13 -5 -2

输出样例:

20


//不知道哪里出毛病了。。。改好了再贴上来


01-复杂度2 Maximum Subsequence Sum   (25分)


Given a sequence of KKK integers { N1N_1N1,N2N_2N2, ..., NKN_KNK }. A continuous subsequence is defined to be { NiN_iNi,Ni+1N_{i+1}Ni+1, ..., NjN_jNj } where 1≤i≤j≤K1 \le i \le j \le K1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integerKKK (≤10000\le 1000010000). The second line contains KKK numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices iii and jjj (as shown by the sample case). If all the KKK numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4


这道题目的大概意思是:

输入:

N(给定的N个数据)

输出:

最大子列和,最大子列和的首尾数据

#include <stdio.h>

void MaxSubqueueSum(int A[], int N)
{
	int ThisSum = 0;
	int MaxSum = 0;
	int i, k;
	int begin, end;
	
	for(i = 0; i < N; i++){
		ThisSum += A[i];	//子列和 
		//如果本次累加的总和超过历史最大总和,则更新 
		if(ThisSum > MaxSum){
			MaxSum = ThisSum;
			k = i;		//标记终点的位置 
		}
		//如果子列和小于0,则令其为0,没必要再累加 
		else if(ThisSum < 0){
			ThisSum = 0;
		}	
	}
	//判断起点终点的位置 
	end = A[k];
	for(; k > 0 && A[k] > 0; k--)
		begin = A[k];	//起点肯定要大于0 
	printf("%d %d %d",MaxSum, begin, end);
}

int main()
{
	int N, i, Num;
	scanf("%d",&N);
	int A[N];
	
	for(i = 0; i < N; i++){
		scanf("%d",&Num);
		A[i] = Num;
	}
	MaxSubqueueSum(A, N);
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值