HDU 6343 Graph Theory Homework(水题)

Problem Description

There is a complete graph containing n vertices, the weight of the i -th vertex is wi .
The length of edge between vertex i and j (i≠j) is ⌊|wi−wj|−−−−−−−√⌋ .
Calculate the length of the shortest path from 1 to n .

 

Input

The first line of the input contains an integer T (1≤T≤10) denoting the number of test cases.
Each test case starts with an integer n (1≤n≤105) denoting the number of vertices in the graph.
The second line contains n integers, the i -th integer denotes wi (1≤wi≤105) .

 

Output

For each test case, print an integer denoting the length of the shortest path from 1 to n .

 

Sample Input

 

1

3

1 3 5

 

Sample Output

 

2

贴过来后公式混乱,题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6343

题目大意:给出边权求最短路。

思路:嗯,最短路,套模板,dij?不行,10^5,SPFA?来一发,,套模板也超时???看神仙的提交记录,0ms?看来有问题。然后发现,,,两点之间直线最短...(题解中说的是三角形两边和大于第三边)。

代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
int k[100005];
int main()
{
    int n,m;
    scanf("%d",&n);
    while(n--){
        scanf("%d",&m);
        for(int i=0;i<m;i++) scanf("%d",&k[i]);
        //sort(k,k+m);
        int b=abs(k[m-1]-k[0]);
        int c=int(sqrt(b));
        printf("%d\n",c);
    }
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值