POJ 1328 Radar Installation(贪心)

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.


Figure A Sample Input of Radar Installations


 

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

描述:

假设海岸线是一条无限延伸的直线。它的一侧是陆地,另一侧是海洋。每一座小岛是在海面上的一个点。雷达必须安装在陆地上(包括海岸线),并且每个雷达都有相同的扫描范围d。你的任务是建立尽量少的雷达站,使所有小岛都在扫描范围之内。

数据使用笛卡尔坐标系,定义海岸线为x轴。在x轴上方为海洋,下方为陆地。

输入格式:

 

第一行包括2个整数n和d,n是岛屿数目,d是雷达扫描范围。

接下来n行为岛屿坐标。

 

输出格式:

 

一个整数表示最少需要的雷达数目,若不可能覆盖所有岛屿,输出“-1”

思路:求的是最少数量,因为每个点对应圆心映射到x轴是一个与d.y相关的区间.所以问题转化成了典型的区间取点问题,使用贪心的做法。直角三角形公式得区间为x-sqrt(d*d-y*y)到x+sqrt(d*d-y*y),先按x轴排序,遍历若存在左边界大于当前区间右边界即圆心数量加1。

代码如下:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<math.h>
#define per(i,a,b) for(int i=a;i<=b;++i)
#define inf 0xf3f3f3f
#define ll long long
using namespace std;
struct node{
	double x;
	double x1;
}p[1005];
int cmp(node a,node b)
{
	if(a.x1==b.x1) return a.x>b.x;
	return a.x1<b.x1;
}
int n,d;
double x,y;
int main()
{
	int fag=0,s,l=1;
	while(scanf("%d%d",&n,&d)!=EOF){ if(n==0&&d==0) return 0;
	s=0;fag=0;
	per(i,1,n) 
	{
	    scanf("%lf%lf",&x,&y);
	    if(y>d) fag=1;
	    p[i].x=x-sqrt(d*d-y*y);
	    p[i].x1=x+sqrt(d*d-y*y);
	}
	if(fag==1) 
	{
		printf("Case %d: ",l);l++;
		printf("-1\n");continue;
	}
	sort(p+1,p+n+1,cmp);
	double k=-inf;
	per(i,1,n)
	{
		if(k<p[i].x)
		{
			s++;k=p[i].x1;
		}
	}
	printf("Case %d: ",l);l++;
	printf("%d\n",s);} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值