2132: 中南大学2017年ACM暑期集训前期训练题集(入门题)

S: Shopaholic

      Time Limit: 1 Sec       Memory Limit: 128 Mb       Submitted: 97       Solved: 46    

Description

Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease, but try to limit its effect on her wallet.
You have realized that the stores coming with these offers are quite selective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250, 200, 150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and 250, she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding up to a total discount of 350.
Your job is to find the maximum discount Lindsay can get.

Input

The first line of input gives the number of test scenarios, 1<=t<=20. Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1<=n<=20000. The next line gives the prices of these items, 1<=pi<=20000.

Output

For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time.

Sample Input

1
6
400 100 200 350 300 250

Sample Output

   
   
400
题目大意:
这个题的意思是某商场,举办促销活动,买三件商品,只需要支付两件商品的费用,(但是需要注意的是:商场不傻一定让你付贵的两件商品,而那件便宜的商品才是免费的)。让你求最多可以省多少钱。
题目解析:
这是一个简单题,为了节约更多的钱,只要对这些商品的价格进行一下排序就可以了,然后是三的倍数的直接相加,就是最多可以节约的钱。
代码:
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
    int T,i,a[20005];
    int ans;
    cin>>T;
    while(T--)
    {
        memset(a,0,sizeof(a));
        ans=0;
        int n;
        cin>>n;
        for(i=1;i<=n;i++)
            cin>>a[i];
        sort(a+1,a+n+1,greater<int>());
        for(i=1;i<=n;i++)
        {
            if(i%3==0)
                ans+=a[i];
        }
        cout<<ans<<endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值