Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47684 Accepted Submission(s): 18044
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
题意是求n的n次方,并且仅输出最后一位。
数据比较大,在快速幂过程中对数据取10的余数即可。
代码如下:
#include <cstdio>
#include <algorithm>
#include<math.h>
#include<string.h>
using namespace std;
__int64 quickpow(__int64 n,__int64 m,__int64 mod)
{
__int64 a=1,b=n;
while(m)
{
if(m&1) a=(a*b)%mod;
b=(b*b)%mod;
m>>=1;
}
return a;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
__int64 n,mod=10;
scanf("%I64d",&n);
printf("%I64d\n",quickpow(n,n,mod));
}
return 0;
}