Red packet 二分算法

Red packet
Time Limit:1000MS Memory Limit:65535KB 64bit IO Format:%I64d & %I64u

Description
New Year is coming! Our big boss Wine93 will distribute some “Red Package”, just like Alipay and Wechat.

Wine93 has m yuan, he decides to distribute them to n people and everyone can get some money(0 yuan is not allowed and everyone’s money is an integer), Now k people has gotten money, it’s your turn to get “Red Package”, you want to know, at least how much money to give you, then you can must become the “lucky man”. and the m yuan must be used out.

Noting that if someone’s money is strictly much than others’, than he is “lucky man”.

Input
Input starts with an integer T (T <= 50) denoting the number of test case.
For each test case, three integers n, m, k (1 <= k < n <= 100000, 0< m <= 100000000) will be given.
Next line contains k integers, denoting the money that k people get. You can assume that the k integers’ summation is no more than m.
Output
Ouput the least money that you need to become the “lucky man”, if it is impossible, output “Impossible” (no quote).
Sample Input
3
3 5 2
2 1
4 10 2
2 3
4 15 2
3 5
Sample Output
Impossible
4
6

这个题就是抢红包呗,二分直接算,但是注意在二分之前的各种判断。
代码如下:

#include<cstdio>
#include<algorithm>
using namespace std;
int n,m,k,sum,ans,a[100000+11],ri,le,mid,max0;
bool f(int x)
{
    if(x <= max0)
        return 0;
    if(x > (m-sum-x-(n-k-2)))
        return 1;
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        max0=0;
        scanf("%d %d %d",&n,&m,&k);
        for(int i = 0 ; i < k ; i++)
        {
            scanf("%d",&a[i]);
            max0=max(max0,a[i]);
            sum+=a[i];
        }
        if((m-sum-(n-k-1))<= max0)
        {
            printf("Impossible\n");
            continue;
        }
        le=max0;
        ri=m-sum-(n-k-1);
        while(le <= ri)
        {
            mid=( le + ri)/2;
            if(f(mid))
            {
                ans=mid;
                ri=mid-1;
            }
            else
            {
                le=mid+1;
            }
        }
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值