POJ - 1743 Musical Theme 后缀数组模板

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings. 
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it: 

  • is at least five notes long 
  • appears (potentially transposed -- see below) again somewhere else in the piece of music 
  • is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)


Transposed means that a constant positive or negative value is added to every note value in the theme subsequence. 
Given a melody, compute the length (number of notes) of the longest theme. 
One second time limit for this problem's solutions! 

Input

The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes. 
The last test case is followed by one zero. 

Output

For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.

Sample Input

30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0

Sample Output

5

题意:

求不重叠的最长公共子串长度,由于题意是判断趋势相等,所以满足条件的最小长度就变成了5 - 1 = 4,计算相邻两项的差值,为了防止出现负数,就在每个差值上一个大数使其为正,用二分枚举字串长度,利用height数组的特性,将后缀字串以不小于k来分组,对每一组求出最大和最小的sa,如果差值大于k就说明存在长度大于k的两个子串具有相同的趋势并且不重叠,保存当前的mid值,继续二分。借鉴了网上大牛的后缀数组模板,后缀数组学了好久才明白,orz。

AC代码

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
#include<string>
#include<map>
#define rep(i,a,n) for(int i=a;i<n;i++)
#define per(i,a,n) for(int i=n-1;i>=a;i--)
#define fori(x) for(int i=0;i<x;i++)
#define forj(x) for(int j=0;j<x;j++)
#define memset(x,y) memset(x,y,sizeof(x))
#define memcpy(x,y) memcpy(x,y,sizeof(y))
#define sca(x) scanf("%d", &x)
#define scas(x) scanf("%s",x)
#define sca2(x,y) scanf("%d%d",&x,&y)
#define sca3(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define scl(x) scanf("%lld",&x)
#define scl2(x,y) scanf("%lld%lld",&x,&y)
#define scl3(x,y,z) scanf("%lld%lld%lld",&x,&y,&z)
#define pri(x) printf("%d\n",x)
#define pri2(x,y) printf("%d %d\n",x,y)
#define pris(x) printf("%s\n",x)
#define prl(x) printf("%lld\n",x)
//#include <bits/stdc++.h>
// for(I[1]=1,i=2;i<100005;i++)I[i]=(ll)(P-P/i)*I[P%i]%P;   求逆元
typedef long long ll;
const int maxn=1e6+7;
const int mod=1e9+7;
const double eps=1e-8;

using namespace std;


const int N = 20000 + 10, INF = 0x3f3f3f3f;
int sa[N], height[N], rnk[N], c[N], wa[N], wb[N];
bool cmp(int *r, int a, int b, int l)
{
    return r[a] == r[b] && r[a+l] == r[b+l];
}
void Rsort(int *x, int *y, int n, int m)
{
    for(int i = 0; i < m; i++) c[i] = 0;
    for(int i = 0; i < n; i++) c[x[y[i]]]++;
    for(int i = 1; i < m; i++) c[i] += c[i-1];
    for(int i = n-1; i >= 0; i--) sa[--c[x[y[i]]]] = y[i];
}
void da(int *s, int n, int m)
{
    int *x = wa, *y = wb;
    for(int i = 0; i < n; i++) x[i] = s[i], y[i] = i;
    Rsort(x, y, n, m);
    for(int j = 1, p = 1; p < n; j *= 2, m = p)
    {
        p = 0;
        for(int i = n-j; i < n; i++) y[p++] = i;
        for(int i = 0; i < n; i++) if(sa[i] >= j) y[p++] = sa[i] - j;
        Rsort(x, y, n, m);
        swap(x, y);
        p = 1; x[sa[0]] = 0;
        for(int i = 1; i < n; i++) x[sa[i]] = cmp(y, sa[i-1], sa[i], j) ? p-1 : p++;
    }
}
void get_height(int *s, int n)
{
    int i, j, k = 0;
    for(i = 0; i <= n; i++) rnk[sa[i]] = i;
    for(i = 0; i < n; height[rnk[i++]] = k)
        for(k ? --k : 0, j = sa[rnk[i]-1]; s[i+k] == s[j+k]; k++);
}
int n;
int a[maxn];

bool check(int m)
{
  int mn = sa[1];
  int ma = sa[1];
  rep(i,2,n+1)
  {
    if(height[i] < m)
    {
      mn = sa[i];
      ma = sa[i];
      continue;
    }
    mn = min(mn,sa[i]);
    ma = max(ma,sa[i]);
    if(ma - mn > m)
      return true;
  }
  return false;
}



int main()
{
  while(sca(n) && n)
  {
    rep(i,0,n)
    {
      sca(a[i]);
    }
    if(n<10)
    {
      pri(0);
      continue;
    }
    rep(i,0,n-1)
    {
      a[i] = a[i+1] - a[i] + 100;
    }
    a[--n] = 0;
    // rep(i,0,n)
    // {
    //   cout<<a[i]<<" ";
    // }
    // cout<<endl;
    da(a,n+1,200);
    get_height(a,n);
    int l = 0,r = n,res = 0;
    int mid;
    while(l<=r)
    {
        mid = (l+r)/2;
        if(check(mid))
        {
          res = mid;
          l = mid + 1;
        }
        else
        {
          r = mid - 1;
        }
    }
    if(res < 4)
      pri(0);
    else
      {
        pri(res + 1);
      }
  }

  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值