HDU 1237 简单计算器

 简单计算器
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。 
 

Input

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。 
 

Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。 
 

Sample Input

     
     
1 + 2 4 + 2 * 5 - 7 / 11 0
 

Sample Output

     
     
3.00 13.36

 

易错点:1.如果单纯的判断第一个字符是不是0,则很容易出错,例如  0+1   。。。。。

                 2.栈内残余对下一步计算无影响


<pre name="code" class="cpp">#include<iostream>
#include<stdio.h>
#include<string>
#include<string.h>
#include<cmath>
#include<stack>
using namespace std;
int main()
{
    int i,len;
    double a,b;
    char str[250],c;
    while(gets(str),strcmp(str,"0")!=0)
    {
        stack<double>s1;
    stack<char>s2;
        i=0;
        len=strlen(str);
        while(i<len){
       if(str[i]>='0'&&str[i]<='9')
       {
           a=0;
           while(str[i]>='0'&&str[i]<='9'){
            a=a*10+str[i]-'0';
            i++;
           }
           i--;
           s1.push(a);
       }
       else if(str[i]=='+'||str[i]=='-')
       {
           if(!s2.empty()){
                a=s1.top();
        s1.pop();
        b=s1.top();
        s1.pop();
        c=s2.top();
         s2.pop();
         if(c=='+')
         a=a+b;
         else a=b-a;
         s1.push(a);
         s2.push(str[i]);

           }
           else{
                s2.push(str[i]);


           }
       }
    else if(str[i]=='/')
       {
           i+=2;
           a=0;
           while(str[i]>='0'&&str[i]<='9')
           {
               a=a*10+str[i]-'0';
            i++;
           }
           i--;
           b=s1.top();
           s1.pop();
           a=b/a;
           s1.push(a);

       }
      else  if(str[i]=='*')
       {
           i+=2;
           a=0;
           while(str[i]>='0'&&str[i]<='9')
           {
               a=a*10+str[i]-'0';
            i++;
           }
           i--;
           b=s1.top();
           s1.pop();
           a=b*a;
           s1.push(a);

       }
       i++;
        }
       while(!s2.empty()){
        a=s1.top();
        s1.pop();
        b=s1.top();
        s1.pop();
        c=s2.top();
         s2.pop();
         if(c=='+')
         a=a+b;
         else a=b-a;
         s1.push(a);
       }
    printf("%.2lf\n",s1.top());
    }
    return 0;
}


 
   

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值