HDU 1019 Least Common Multiple【GCD】

8 篇文章 0 订阅

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46314    Accepted Submission(s): 17431


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
  
  
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
  
  
105 10296
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1005  1021  1008  1049  1108 
 

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
using namespace std;

int gcd(int a,int b)
{
    if(a<b)swap(a,b);
    return b?gcd(b,a%b):a;
}

int main()
{
    int t,n;//t表示测试数组,n表示每组测试数据的个数
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int num,Maxn;//num表示测试数据,Maxn表示最大公约数;
        scanf("%d",&num);
        Maxn=num;
        for(int i=1;i<n;i++)
        {
            scanf("%d",&num);
            Maxn=Maxn/gcd(Maxn,num)*num;
        }
        printf("%d\n",Maxn);
    }
    return 0;
}

注:
    Maxn=Maxn/gcd(Maxn,num)*num;  的顺序如果是Maxn*num/gcd(Maxn,num)可能会因炸掉int而错误!!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值