HDU 4403 A very hard Aoshu problem【DFS】

31 篇文章 0 订阅

A very hard Aoshu problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1409    Accepted Submission(s): 958


Problem Description
Aoshu is very popular among primary school students. It is mathematics, but much harder than ordinary mathematics for primary school students. Teacher Liu is an Aoshu teacher. He just comes out with a problem to test his students:

Given a serial of digits, you must put a '=' and none or some '+' between these digits and make an equation. Please find out how many equations you can get. For example, if the digits serial is "1212", you can get 2 equations, they are "12=12" and "1+2=1+2". Please note that the digits only include 1 to 9, and every '+' must have a digit on its left side and right side. For example, "+12=12", and "1++1=2" are illegal. Please note that "1+11=12" and "11+1=12" are different equations.
 

Input
There are several test cases. Each test case is a digit serial in a line. The length of a serial is at least 2 and no more than 15. The input ends with a line of "END".
 

Output
For each test case , output a integer in a line, indicating the number of equations you can get.
 

Sample Input
  
  
1212 12345666 1235 END
 

Sample Output
  
  
2 2 0
从左向右一个一个位置的放等号,看左右是否能通过相等
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
typedef long long LL;
const int INF=0x7ffffff;

const int M=25;
char s[M];
LL num[M][M];
int i,j,k,n,m;
int ans ,len,l;

LL get(int x,int y)
{
    LL sum=0;
    for(int i=x;i<=y;i++)
        sum=sum*10+s[i]-'0';
    return sum;
}

void f(int i,int sum1,int sum2)
{
    if(i>=len){
        if(sum1==sum2)ans++;
        return;
    }
    for(int k=i;k<len;k++)
        f(k+1,sum1,sum2+num[i][k]);
}

void dfs(int i,int sum1)
{
    if(i>=l)
        f(i,sum1,0);
    for(int k=i;k<l;k++)
        dfs(k+1,sum1+num[i][k]);
}

int main()
{
    while(~scanf("%s",s))
    {
        if(s[0]=='E')break;
        len=strlen(s);
        rep(i,0,len)
          rep(j,i,len)
             num[i][j]=get(i,j);
         int r;ans=0;
        rep(r,1,len){
          l=r;
          dfs(0,0);
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值