To Miss Our Children Time
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)Total Submission(s): 4662 Accepted Submission(s): 1291
Problem Description
Do you remember our children time? When we are children, we are interesting in almost everything around ourselves. A little thing or a simple game will brings us lots of happy time! LLL is a nostalgic boy, now he grows up. In the dead of night, he often misses something, including a simple game which brings him much happy when he was child. Here are the game rules: There lies many blocks on the ground, little LLL wants build "Skyscraper" using these blocks. There are three kinds of blocks signed by an integer d. We describe each block's shape is Cuboid using four integers ai, bi, ci, di. ai, bi are two edges of the block one of them is length the other is width. ci is
thickness of the block. We know that the ci must be vertical with earth ground. di describe the kind of the block. When di = 0 the block's length and width must be more or equal to the block's length and width which lies under the block. When di = 1 the block's length and width must be more or equal to the block's length which lies under the block and width and the block's area must be more than the block's area which lies under the block. When di = 2 the block length and width must be more than the block's length and width which lies under the block. Here are some blocks. Can you know what's the highest "Skyscraper" can be build using these blocks?
thickness of the block. We know that the ci must be vertical with earth ground. di describe the kind of the block. When di = 0 the block's length and width must be more or equal to the block's length and width which lies under the block. When di = 1 the block's length and width must be more or equal to the block's length which lies under the block and width and the block's area must be more than the block's area which lies under the block. When di = 2 the block length and width must be more than the block's length and width which lies under the block. Here are some blocks. Can you know what's the highest "Skyscraper" can be build using these blocks?
Input
The input has many test cases.
For each test case the first line is a integer n ( 0< n <= 1000) , the number of blocks.
From the second to the n+1'th lines , each line describing the i‐1'th block's a,b,c,d (1 =< ai,bi,ci <= 10^8 , d = 0 or 1 or 2).
The input end with n = 0.
For each test case the first line is a integer n ( 0< n <= 1000) , the number of blocks.
From the second to the n+1'th lines , each line describing the i‐1'th block's a,b,c,d (1 =< ai,bi,ci <= 10^8 , d = 0 or 1 or 2).
The input end with n = 0.
Output
Output a line contains a integer describing the highest "Skyscraper"'s height using the n blocks.
Sample Input
3 10 10 12 0 10 10 12 1 10 10 11 2 2 10 10 11 1 10 10 11 1 0
Sample Output
24 11
Source
注意:d值一定要排序;
因为D值越大,对大小堆叠的要求越严格,还有,长和宽可交换
#include<cstdio>
#include<math.h>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define rep(i,j,k)for(i=j;i<k;i++)
#define per(i,j,k)for(i=j;i>k;i--)
#define MS(x,y)memset(x,y,sizeof(x))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ll long long
#define abs(x) (x>0?x:-x)
const int INF=0x7ffffff;
const int M=1000+1;
ll dp[M];
int n;
struct node
{
int a,b,c,d;
}x[M];
bool cmp(node x,node y)
{
if(x.a!=y.a)return x.a>y.a;
if(x.b!=y.b)return x.b>y.b;
return x.d<y.d;
}
void DP()
{
ll ans=x[0].c;
for(int i=0;i<n;i++){
dp[i]=x[i].c;
ans=max(ans,dp[i]);
}
for(int i=n-1;i>=0;i--){
if(x[i].d==0){
for(int j=n-1;j>i;j--){
if(x[j].a<=x[i].a&&x[j].b<=x[i].b)
dp[i]=max(dp[i],dp[j]+x[i].c);
}
}
if(x[i].d==1){
for(int j=n-1;j>i;j--){
if(x[j].a<x[i].a&&x[j].b<=x[i].b||(x[j].a<=x[i].a&&x[j].b<x[i].b))
dp[i]=max(dp[i],dp[j]+x[i].c);
}
}
if(x[i].d==2){
for(int j=n-1;j>i;j--){
if(x[j].a<x[i].a&&x[j].b<x[i].b)
dp[i]=max(dp[i],dp[j]+x[i].c);
}
}
ans=max(ans,dp[i]);
}
printf("%lld\n",ans);
}
int main()
{
while(~scanf("%d",&n),n){
for(int i=0;i<n;i++){
scanf("%d%d%d%d",&x[i].a,&x[i].b,&x[i].c,&x[i].d);
if(x[i].a<x[i].b)
swap(x[i].a,x[i].b);
}
sort(x,x+n,cmp);
DP();
}
return 0;
}