2017女生赛 1005 Easy Summation【】

Easy Summation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
You are encountered with a traditional problem concerning the sums of powers.
Given two integers  n  and  k . Let  f(i)=ik , please evaluate the sum  f(1)+f(2)+...+f(n) . The problem is simple as it looks, apart from the value of  n  in this question is quite large.
Can you figure the answer out? Since the answer may be too large, please output the answer modulo  109+7 .
 

Input
The first line of the input contains an integer  T(1T20) , denoting the number of test cases.
Each of the following  T  lines contains two integers  n(1n10000)  and  k(0k5) .
 

Output
For each test case, print a single line containing an integer modulo  109+7 .
 

Sample Input
  
  
3 2 5 4 2 4 1
 

Sample Output
  
  
33 30 10
当时一激动没考虑到直接pow超出了longlong范围wa了两发
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b)  memset(a,b,sizeof(a))
const int M=1e5+10;
const int inf=0x3f3f3f3f;
int i,j,k,n,m;
const ll mod=1e9+7;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&k);
        ll ans=0;
        for(int i=1;i<=n;i++){
             ll sum=1;
            for(int j=1;j<=k;j++)
               sum*=i,sum%=mod;
            ans+=sum;
            ans%=mod;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值