HDU 6095 Rikka with Competition【】

32 篇文章 0 订阅

Rikka with Competition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 380    Accepted Submission(s): 315


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

A wrestling match will be held tomorrow.  n  players will take part in it. The  i th player’s strength point is  ai .

If there is a match between the  i th player plays and the  j th player, the result will be related to  |aiaj| . If  |aiaj|>K , the player with the higher strength point will win. Otherwise each player will have a chance to win.

The competition rules is a little strange. Each time, the referee will choose two players from all remaining players randomly and hold a match between them. The loser will be be eliminated. After  n1  matches, the last player will be the winner.

Now, Yuta shows the numbers  n,K  and the array  a  and he wants to know how many players have a chance to win the competition.

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number  t(1t100) , the number of the testcases. And there are no more than  2  testcases with  n>1000 .

For each testcase, the first line contains two numbers  n,K(1n105,0K<109) .

The second line contains  n  numbers  ai(1ai109) .
 

Output
For each testcase, print a single line with a single number -- the answer.
 

Sample Input
  
  
2 5 3 1 5 9 6 3 5 2 1 5 9 6 3
 

Sample Output
  
  
5 1
 

Source

题意:n带权值的人参加比赛,裁判员每次从里面选出2个人,如果这俩个人的权值之差大于K,那么这俩个人中权值最大的胜利留下,另一个淘汰出局,否则的话,两个人谁都可以胜利(就是可以随便选一个人留下)。问裁判员进行n-1次操作后,有哪些人有可能剩下?

思路:先对权值排序,然后记录最后一次出现权值之差大于K的位置,因为在这个位置前面的人,意味着一定会输给这个位置的人,不可能赢,在这个位置后面的人意味着都可能成为最后的胜利者。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
#define ll long long
#define ms(a,b)  memset(a,b,sizeof(a))
#define maxn 510
const int M=1e6+10;
const int MM=2e3+10;
const int inf=0x3f3f3f3f;
const int mod=998244353;
const double eps=1e-10;
int n,m,k;
int a[M];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)scanf("%d",&a[i]);
        sort(a+1,a+n+1);
        ll sum=1;
        for(int i=2;i<=n;i++){
            if(a[i]-a[i-1]>k)sum=i;
        }
        printf("%d\n",n-sum+1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值