Cantor表 [cantor]

10 篇文章 0 订阅

题目描述:

现代数学的著名证明之一是Georg Cantor证明了有理数是可枚举的。他是用下面这一张表来证明这一命题的:

 

我们以Z字形给上表的每一项编号。第一项是1/1,然后是1/2,2/1,3/1,2/2,…

输入格式

整数N(1≤N≤10000000)

输出格式

表中的第N项

输入输出样列

输入样例1:

7

输出样例1:

 1/4

说明

1999年普及组第一题

【耗时限制】1000ms 【内存限制】128MB

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string.h>
#include <sstream>
#include <cstring>
#include <algorithm>
using namespace std;

int main(){
    int i = 0, n, s = 0, x, y;
    cin >> n;
    while(s < n){
        i++;
        s += i;
    }
    s -= i;
    if(i % 2 == 1){
        x = i, y = 1, s++;
        while(s < n)
            x--, y++, s++;
    }
    else{
        x = 1, y = i, s++;
        while(s < n)
            x++, y--, s++;
    }
    cout << x << '/' << y;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值