华为5700交换机DHCP基础配置案例

华为5700交换机DHCP基础配置案例

 

 

配置两个地址池:192.168.1.0/24和192.168.2.0/24

配置两个VLAN:10和20

将四台主机分别加入VLAN

自动获取IP地址,确保全网互通。

步骤:

  • DHCP交换机上

在DHCP交换机上创建VLAN10,20;IP地址池VLAN 10和IP地址池 VLAN 20

[DHCP]DHCP enable        //打开DHCP功能

[DHCP]vlan batch 10 20     //创建两个Vlan 10和20

[DHCP]ip pool vlan10       //新增地址池名称为 Vlan10

[DHCP]gateway-list 192.168.1.254     //设置网关

[DHCP]network 192.168.1.0 mask 255.255.255.0    //设置地址段

[DHCP]excluded-ip-address 192.168.1.200 192.168.1.253     //可以设置排除IP范围

[DHCP]lease day 5   //设置获取到IP地址的有效期为5天  

[DHCP]dns-list 114.114.114.114   //设置客户机DNS,多条命令可设置多个

 

[DHCP]ip pool VLAN 20           //新增地址池名称为 Vlan20

[DHCP]gateway-list 192.168.2.254    //设置网关

[DHCP]network 192.168.2.0 mask 255.255.255.0    //设置地址池

[DHCP]excluded-ip-address 192.168.2.100 192.168.1.200   //可以设置排除IP范围

[DHCP]lease day 5    //设置获取到IP地址的有效期为5天

[DHCP]dns-list 8.8.8.8  //设置客户机DNS,多条命令可设置多个

 

分配vlanif 端口配置

[DHCP]interface vlanif10    //进入vlanif10接口

[DHCP]ip address 192.168.1.254 255.255.255.0  //配置接口IP

[DHCP]dhcp select global

 

[DHCP] interface vlanif20     //进入vlanif10接口

[DHCP]ip address 192.168.2.254 255.255.255.0  //配置接口IP

[DHCP]dhcp select global

 

给DHCP服务器1口和2口配置trunk链路

[DHCP]interface g0/0/1

[DHCP]port link-type trunk

[DHCP]port trunk allow-pass Vlan 10

[DHCP]interface g0/0/2

[DHCP]port link-type trunk

[DHCP]port trunk allow-pass Vlan 20

 

二、SW1交换机上

[SW1]DHCP enable         //打开DHCP功能

在交换机一上把端口1;2加入VLAN 10;端口3设置成trunk链路

[SW1]vlan batch 10          //创建两个Vlan 10

[SW1]interface g0/0/1        //进入接口1

[SW1]port link-type access     //配置接口类型为access

[SW1]port default vlan 10      //接口配置属于Vlan10

[SW1]interface g0/0/2         //进入接口2

[SW1]port link-type access      //配置接口类型access

[SW1]port default vlan 10      //接口配置属于Vlan10

[SW1]interface g0/0/3         //进入接口3

[SW1]port link-type trunk        //配置接口类型trunk

[SW1]port trunk allow-pass vlan 10   //配置哪些Vlan充许通过

 

三、SW2交换机上也做相同操作

验证测试保存

已标记关键词 清除标记
相关推荐
三层交换机配置DHCP的解决方案 一,如果不用交换机DHCP功能而是利用PC的DHCP功能!   1.在交换机配置DHCP服务器:   ip dhcp-server 192.168.0.69   2.在交换机中为每个VLAN设置同样的DHCP服务器的IP地址: interface Vlan11 ip address 192.168.1.254 255.255.255.0 ip helper-address 192.168.0.69 DHCP Server IP interface Vlan12 ip address 192.168.2.254 255.255.255.0 ip helper-address 192.168.0.69 DHCP Server IP   3.在DHCP服务器上设置网络地址分别为192.168.1.0、192.168.2.0的作用域,并将这些作用域的“路   由器“选项设置为对应VLAN的接口IP地址。   二 利用三层交换机自带的DHCP功能实现多VLAN的IP地址自动分配   (一) 配置方法一   1.同时为多个VLAN的客户机分配地址   2.VLAN内有部分地址采用手工分配的方式   3.为客户指定网关、Wins服务器等   4.VLAN 2的地址租用有效期限为1天,其它为3天   5.按MAC地址为特定用户分配指定的IP地址   最终配置如下: ip dhcp excluded-address 10.1.1.1 10.1.1.19 //不用于动态地址分配的地址 ip dhcp excluded-address 10.1.1.240 10.1.1.254 ip dhcp excluded-address 10.1.2.1 10.1.2.19 ! ip dhcp pool global //global是pool name, 由用户指定 network 10.1.0.0 255.255.0.0 //动态分配的地址段 domain-name client.com //为客户机配置域后缀 dns-server 10.1.1.1 10.1.1.2 //为客户机配置dns服务器 netbios-name-server 10.1.1.5 10.1.1.6 //为客户机配置wins服务器 netbios-node-type h-node //为客户机配置节点模式(影响名称解释的顺利,如h-node=先通过wins服务器解释...) lease 3 //地址租用期限: 3天 ip dhcp pool vlan1 network 10.1.1.0 255.255.255.0 //本pool是global的子pool, 将从global pool继承domain-name等 option default-router 10.1.1.100 10.1.1.101 //为客户机配置默认网关 ! ip dhcp pool vlan2 //为另一VLAN配置的pool network 10.1.2.0 255.255.255.0 default-router 10.1.2.100 10.1.2.101 lease 1 ! ip dhcp pool vlan1_john //总是为MAC地址为...的机器分配...地址 host 10.1.1.21 255.255.255.0 client-identifier 010050.bade.6384 //client-identifier=01加上客户机网卡地址 !ip dhcp pool vlan1_tom host 10.1.1.50 255.255.255.0 client-identifier 010010.3ab1.eac8
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页