SDUT1197约瑟夫问题

约瑟夫问题

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

n个人想玩残酷的死亡游戏,游戏规则如下: 

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。

输入

输入n和m值。

输出

输出胜利者的编号。

示例输入

5 3

示例输出

4

提示

第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *Creat_List(int n)
{
    struct node *head,*p,*tail;
    p=(struct node *)malloc(sizeof(struct node));
    p->data=1;
    p->next=NULL;
    head=p;
    tail=p;

    for(int i=2;i<=n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        p->data=i;
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    tail->next=head;
return head;
}
int Sel_Elem(struct node *head,int n,int m)
{
    int num=0;//计数变量;
    int Count=0;//统计出圈数变量;
    struct node *p,*q;
    q=head;
    while(q->next!=head)//前驱结点指向尾结点;
        q=q->next;
    while(Count<n-1)
    {
        p=q->next;
        num++;
        if(num%m==0)//找到一个被删结点
        {
            q->next=p->next;
            free(p);
            Count++;
        }
        else q=p;
    }
    return q->data;
}
int main()
{
    struct node *head;
    int n,m,k;
    while(~scanf("%d %d",&n,&m))
    {
        head=Creat_List(n);
        k=Sel_Elem(head,n,m);
        printf("%d\n",k);
    }
 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值