显示所有学生数据

题目描述

现有有N个学生的数据记录,每个记录包括学号、姓名、三科成绩。编写一个函数input,用来输入一个学生的数据记录。编写一个函数print,打印一个学生的数据记录。在主函数调用这两个函数,读取N条记录输入,再按要求输出。 N<100

输入

学生数量N占一行,每个学生的学号、姓名、三科成绩占一行,空格分开。

输出

每个学生的学号、姓名、三科成绩占一行,逗号分开。

样例输入 Copy

3
1101 clan 80 70 60
1102 blue 90 80 70
1103 xds  59 99 98

样例输出 Copy

1101,clan,80,70,60
1102,blue,90,80,70
1103,xds,59,99,98
#include <stdio.h>
struct student{
	int number;
	char name[100];
	int score1,score2,score3;
	
}stu[100];
int input(int n){
	int i;
	for(i=0;i<n;i++){
		scanf("%d %s %d %d %d",&stu[i].number,stu[i].name,&stu[i].score1,&stu[i].score2,&stu[i].score3);
} }
void print(int n){//不返回结果的函数定义中,void不能省略,否则,函数类型被默认为定义int
	int i;
	for(i=0;i<n;i++){
		 printf("%d,%s,%d,%d,%d\n",stu[i].number,stu[i].name,stu[i].score1,stu[i].score2,stu[i].score3);
} 
}
int main(void){
	int n;

	scanf("%d",&n);
	input(n);
    print(n);
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值