hdu-2147kiki's game-博弈



Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
  
  
5 3 5 4 6 6 0 0
 

Sample Output
  
  
What a pity! Wonderful! Wonderful!
 

题意:一个n*m的表格,起始位置为右上角,目标位置为左下角,甲先开始走,走的规则是可以向左,向下或者向左下(对顶的)走一格。谁先走到目标位置谁就胜利。在甲乙都采用最佳策略的时候,先走者能否获胜。也是一个巴什博弈的题目。首先画出PN图,

又是一道NP状态转换的巴什博弈。这题根据NP状态转移最好画个表格,规律就很直观了。

博弈么,从左下角往前推:
P→到达该点后,下一个人必败。
N→到达该点后,下一个人必胜。
显然,最左下角的点是P。
然后根据经过一步操作可到达必败状态的都是必胜状态,下一步操作都是必胜状态,那么这步操作时必败状态的原则一步步的去画表格就可以了。
       
       
       
       
       
       
P      
这是7*7的表格,如图1,7位置为P。
由于1,6和2,7位置只能向1,7位置移动,所以1,6与2,7为N。
       
       
       
       
       
N      
PN     

同理,第1列和第7行就可以填充完毕。
P      
N      
P      
N      
P      
N      
PNPNPNP
再反观2,6位置,作为2,6位置上的人,想赢得这场比赛,所以肯定会向1,7移动,因此2,6也是N
P      
N      
P      
N      
P      
NN     
PNPNPNP
每个位置上,都会向赢比赛的趋向走,所以剩余各个点的P、N都可以填充完毕
PNPNPNP
NNNNNNN
PNPNPNP
NNNNNNN
PNPNPNP
NNNNNNN
PNPNPNP

此图填完,可以找到规律:
只有在行列数均为奇数时,为P,其他情况均为N。

所以此题:若行列均为奇数则Kiki无法赢得比赛。


#include<stdio.h>

int main()
{
    int n, m;
    while(~scanf("%d%d",&n,&m)&&n+m)
    {
        if(n%2 != 0 && m%2 != 0)
            printf("What a pity!\n");
        else
            printf("Wonderful!\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值