poj-2049-Finding Nemo-BFS

6 篇文章 0 订阅
Nemo is a naughty boy. One day he went into the deep sea all by himself. Unfortunately, he became lost and couldn't find his way home. Therefore, he sent a signal to his father, Marlin, to ask for help.
After checking the map, Marlin found that the sea is like a labyrinth with walls and doors. All the walls are parallel to the X-axis or to the Y-axis. The thickness of the walls are assumed to be zero.
All the doors are opened on the walls and have a length of 1. Marlin cannot go through a wall unless there is a door on the wall. Because going through a door is dangerous (there may be some virulent medusas near the doors), Marlin wants to go through as few doors as he could to find Nemo.
Figure-1 shows an example of the labyrinth and the path Marlin went through to find Nemo.

We assume Marlin's initial position is at (0, 0). Given the position of Nemo and the configuration of walls and doors, please write a program to calculate the minimum number of doors Marlin has to go through in order to reach Nemo.

Input

The input consists of several test cases. Each test case is started by two non-negative integers M and N. M represents the number of walls in the labyrinth and N represents the number of doors.
Then follow M lines, each containing four integers that describe a wall in the following format:
x y d t
(x, y) indicates the lower-left point of the wall, d is the direction of the wall -- 0 means it's parallel to the X-axis and 1 means that it's parallel to the Y-axis, and t gives the length of the wall.
The coordinates of two ends of any wall will be in the range of [1,199].
Then there are N lines that give the description of the doors:
x y d
x, y, d have the same meaning as the walls. As the doors have fixed length of 1, t is omitted.
The last line of each case contains two positive float numbers:
f1 f2
(f1, f2) gives the position of Nemo. And it will not lie within any wall or door.
A test case of M = -1 and N = -1 indicates the end of input, and should not be processed.

Output

For each test case, in a separate line, please output the minimum number of doors Marlin has to go through in order to rescue his son. If he can't reach Nemo, output -1.

Sample Input

8 9
1 1 1 3
2 1 1 3
3 1 1 3
4 1 1 3
1 1 0 3
1 2 0 3
1 3 0 3
1 4 0 3
2 1 1
2 2 1
2 3 1
3 1 1
3 2 1
3 3 1
1 2 0
3 3 0
4 3 1
1.5 1.5
4 0
1 1 0 1
1 1 1 1
2 1 1 1
1 2 0 1
1.5 1.7
-1 -1

Sample Output

5
-1



注意有的点不在数据范围内,若遇见应输出0,反思,用BFS时应把数据同传过去,而不是只去附上改变变的量,而不附不变的量,终止条件要确定

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define INF 0x3f3f3f3f
int sx, sy;
struct node
{
    int n,s,w,e;
} mp[410][410];
struct nopo
{
    int x, y;
    int step;
} que[51000],now,next;
int vis[410][410];

void BFS()
{
     int i;
    memset(vis,0,sizeof(vis));
    next.x=sx;
    next.y=sy;
    next.step=0;
    vis[sx][sy]=1;
    int s=0,e=0,ans=INF;
    que[e].x=sx;
    que[e].y=sy;
    que[e++].step=0;
    while(s<e)
    {
        now=que[s++];
        for (i=1;i<=4;i++)
        {
            int flag=0;
            if(i==1)
                if(mp[now.x][now.y].s!=1)
                {
                    next.x=now.x-1;
                    next.y=now.y;
                    if(mp[now.x][now.y].s==2)
                        next.step=now.step+1;
                    else next.step=now.step;
                    flag=1;
                }
            if(i==2)
               if(mp[now.x][now.y].n!=1)
                {
                    next.x=now.x+1;
                    next.y=now.y;
                    if(mp[now.x][now.y].n==2)
                        next.step=now.step+1;
                    else next.step=now.step;
                    flag=1;
                 }
            if(i==3)
                 if(mp[now.x][now.y].w!=1)
                {
                    next.x=now.x;
                    next.y=now.y-1;
                    if(mp[now.x][now.y].w==2)
                        next.step=now.step+1;
                    else next.step=now.step;
                    flag=1;
                 }
            if(i==4)
                if(mp[now.x][now.y].e!=1)
                {
                    next.x=now.x;
                    next.y=now.y+1;
                    if(mp[now.x][now.y].e==2)
                        next.step=now.step+1;
                    else next.step=now.step;
                    flag=1;
                }
             if(next.x<=0||next.x>=200||next.y<=0||next.y>=200)
             {
                 if(next.step<ans)
                ans=next.step;
                continue;
             }

             if(!vis[next.x][next.y]&&flag)
             {
                 vis[next.x][next.y]=1;
                 que[e++]=next;
             }
        }
    }
    if(ans==INF) printf("-1\n");
    else
    printf("%d\n",ans);
}
int main()
{
    int n, m;
    while(~scanf("%d%d",&n,&m)&&(n!=-1||m!=-1))
    {
        memset(mp,0,sizeof(mp));
        while(n--)
        {
            int x, y, b, h;
            scanf("%d%d%d%d",&y,&x,&b,&h);
            if(b == 1)
            {
                for(int i = x; i < x+h; i++)
                {
                    mp[i][y].w = 1;
                    mp[i][y-1].e = 1;
                }
            }
            else
            {
                for(int i = y; i < y+h; i++)
                {
                    mp[x][i].s = 1;
                    mp[x-1][i].n = 1;
                }
            }
        }
        while(m--)
        {
            int x, y, b, h=1;
            scanf("%d%d%d",&y,&x,&b);
            if(b == 1)
            {
                for(int i = x; i < x+h; i++)
                {
                    mp[i][y].w = 2;
                    mp[i][y-1].e = 2;
                }
            }
            else
            {
                for(int i = y; i < y+h; i++)
                {
                    mp[x][i].s = 2;
                    mp[x-1][i].n = 2;
                }
            }
        }
        double qx1, qy1;
        scanf("%lf%lf",&qy1,&qx1);
        sx = (int)qx1;
        sy = (int)qy1;
        if(sx >= 1 && sx < 200 && sy >= 1 && sy < 200)
        {
            BFS();
        }
        else
            printf("0\n");

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值