有关set的一点应用

有关set的一点应用

Problem Description

在长度为n(n<1000)的顺序表中可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只能有一个)。

Input

第一行输入表的长度n;
第二行依次输入顺序表初始存放的n个元素值。

Output

第一行输出完成多余元素删除以后顺序表的元素个数;
第二行依次输出完成删除后的顺序表元素。

Example Input

12
5 2 5 3 3 4 2 5 7 5 4 3

Example Output

5
5 2 3 4 7

代码如下:

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
#include <set>
int main()
{
    int n, x, i, c[1050], a;
    set<int> s;
    while(~scanf("%d", &n))
    {
        int q = -1;
        for(i = 0; i <= n - 1; i++)
        {
            a = *s.end();
            scanf("%d", &x);
            s.insert(x);
            if(*s.end() != a)
            {
               c[++q] = x;
            }
        }
//        set<int>::iterator it;  //利用迭代器输出set
//        for(it = s.begin() ; it != s.end() ; it++)
//        {
//            printf("%d ", *it);
//        }
        int z = s.size();
        printf("%d\n", z);
        for(i = 0; i <= q; i++)
        {
            if(i == q) printf("%d\n", c[i]);
            else printf("%d ", c[i]);
        }
        s.clear();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值