题目:马走日
马在中国象棋以日字形规则移动。
请编写一段程序,给定 n \times mn×m大小的棋盘,以及马的初始位置 (x, y)(x,y),要求不能重复经过棋盘上的同一个点,计算马可以有多少途径遍历棋盘上的所有点。
输入格式
第一行为整数 T(T < 10)T(T<10),表示测试数据组数。
每一组测试数据包含一行,为四个整数,分别为棋盘的大小以及初始位置坐标 n,m,x,yn,m,x,y。(0 \le x \le n-1,0 \le y \le m-1, m < 10, n < 100≤x≤n−1,0≤y≤m−1,m<10,n<10)。
输出格式
每组测试数据包含一行,为一个整数,表示马能遍历棋盘的途径总数,00 为无法遍历一次。
Sample Input
1
5 4 0 0
Sample Output
32
#include<cstdio>
#include<iostream>
#include<cstring>
//dfs模板题
using namespace std;
int book[30][30];
int n,m,t,x,y,ans=0;
int Next[8][2]={{1,2},{2,1},{1,-2},{2,-1},{-1,2},{-1,-2},{-2,-1},{-2,1}};
void dfs(int tx,int ty,int s)
{
if(s==n*m)
ans++;
if(book[tx][ty]==0)
{
book[tx][ty]=1;
for(int i=0; i<8; i++)
{
int xx=tx+Next[i][0];
int yy=ty+Next[i][1];
if(xx<0||xx>=n||yy<0||yy>=m)
continue;
if(book[xx][yy]==1)
continue;
dfs(xx,yy,s+1);
}
book[tx][ty]=0;
}
}
int main()
{
cin>>t;
while(t--)
{
cin>>n>>m>>x>>y;
memset(book,0,sizeof(book));
ans=0;
dfs(x,y,1);
cout<<ans<<endl;
}
}