题目:Prime Ring Problem(素环问题)
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
中文大意
如图所示,一个环由 n 个圆组成。将自然数1、2、…、n分别放入每个圆中,相邻两个圆内数之和应为素数。
注意:第一个圆圈的数量应始终为 1。
输入
n (0 < n < 20)。
输出
输出格式如下所示。每行代表环中从 1 开始顺时针和逆时针的一系列圆圈数字。编号顺序必须满足上述要求。按字典顺序打印解决方案。
您将编写一个完成上述过程的程序。
在每个案例之后打印一个空行。
样本输入
6
8
样本输出
情况1:
1 4 3 2 5 6
1 6 5 2 3 4
案例2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
实现代码:
#include<stdio.h>
#include<string.h>
int n,a[20],b[41],c[20];
int prime(int x)
{
for(int i=2; i*i<=x; i++)
if(x%i==0)
{
return 0;break;
}
return 1;
}
void dfs(int num)
{
if(num==n&&b[a[0]+a[n-1]]==1)
{
for(int i=0;i<n-1;i++)
printf("%d ",a[i]);
printf("%d\n",a[n-1]);
}
else
{
for(int i=2; i<=n; i++)
{
if(!c[i]&&b[i+a[num-1]])
{
a[num]=i;
c[i]=1;
dfs(num+1);
c[i]=0;
}
}
}
}
int main()
{
for(int i=2; i<=40; i++)
{
b[i]=prime(i);
}
int k=1;
while(scanf("%d",&n)!=EOF)
{
a[0]=1;
printf("Case %d:\n",k++);
if(n%2==0)
dfs(1);
printf("\n");
}
}